Template upload results in fields missing from discovery page


(Alex Mendez) #1

Greetings - i have an issue where I upload a template to be applied to indices that start with logstash* , The problem i have is that once I upload it the correct fields get their type, integers to be specific. but all fields are missing from the main discovery field. Removal of the template returns the fields ( after deleting the indices and allowing new data to come in and refreshing the fields, but the field format are gone.) While the template is applied the visualizations I have work fine, but I just can't search the data in the discovery window. The fields are missing on the left hand side though.

Anybody have any idea whats happening.

below is the template.

{
"logstash": {
"order": 0,
"template": "logstash*",
"settings": {
"index": {
"number_of_shards": "5"
}
},
"mappings": {
"application_logs": {
"_source": {
"enabled": false
},
"properties": {
"rs": {
"type": "integer"
},
"lat_time": {
"type": "integer"
},
"pt": {
"type": "integer"
},
"input_bytes": {
"type": "integer"
},
"rtdgp_host": {
"index": "true",
"type": "keyword"
},
"scores": {
"type": "integer"
},
"output_bytes": {
"type": "integer"
},
"app_depth": {
"type": "integer"
},
"net": {
"type": "integer"
},
"iot": {
"type": "integer"
}
}
}
},
"aliases": {}
}
}


(Alex Mendez) #2

SOLUTION: In the template there is an enabled option, that was set to false. Once I enabled it the fields were available.

"mappings": {
"application_logs": {
"_source": {
"enabled": false < -----
},

"mappings": {
"application_logs": {
"_source": {
"enabled": true < ---
},


(Brandon Kobel) #3

@Alex_Mendez I'm glad to hear that you were able to figure out a solution to your issue, and thank you for posting your solution here so others can find it.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.