Term facet problem


(abhiage) #1

I have following data

Action : "added" Product_ID : slr-camera-tripod
Action : "added" Product_ID : slr-camera-tripod

while running term facetson product_ID it shows count like

term : slr count : 2
term : camera count : 2
term : tripod count : 2

which is not appropriate.

It should show like term : slr-camera-tripod count :2

How can I achieve the same?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/099ee59d-1528-4941-8813-22939313a1af%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jun Ohtani) #2

Hi,

Your “Product_ID” field is “analyzed”.
You change the Product_ID field to “not_analyzed” for faceting.

If you want to search analyzed Product_ID field, then you should use multi_field.

See :
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-multi-field-type.html


Jun Ohtani
johtani@gmail.com
blog : http://blog.johtani.info
twitter : http://twitter.com/johtani

2013/12/20 16:00、abhi patel abhiage@gmail.com のメール:

I have following data

Action : "added" Product_ID : slr-camera-tripod
Action : "added" Product_ID : slr-camera-tripod

while running term facetson product_ID it shows count like

term : slr count : 2
term : camera count : 2
term : tripod count : 2

which is not appropriate.

It should show like term : slr-camera-tripod count :2

How can I achieve the same?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/099ee59d-1528-4941-8813-22939313a1af%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(abhiage) #3

Thank you.It worked

On Friday, December 20, 2013 12:37:59 PM UTC+5:30, Jun Ohtani wrote:

Hi,

Your “Product_ID” field is “analyzed”.
You change the Product_ID field to “not_analyzed” for faceting.

If you want to search analyzed Product_ID field, then you should use
multi_field.

See :

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-multi-field-type.html


Jun Ohtani
joh...@gmail.com <javascript:>
blog : http://blog.johtani.info
twitter : http://twitter.com/johtani

2013/12/20 16:00、abhi patel <abh...@gmail.com <javascript:>> のメール:

I have following data

Action : "added" Product_ID : slr-camera-tripod
Action : "added" Product_ID : slr-camera-tripod

while running term facetson product_ID it shows count like

term : slr count : 2
term : camera count : 2
term : tripod count : 2

which is not appropriate.

It should show like term : slr-camera-tripod count :2

How can I achieve the same?

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/099ee59d-1528-4941-8813-22939313a1af%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f2e55077-85d1-421d-9a77-07a9383b525f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4