The response action does not work

Friends! Thank you all. The problem is solved.

I changed the EQL query to a new one:

registry where host.os.type == "windows" and
  event.type == "change" and
  registry.path : "HKLM\\SAM\\SAM\\Domains\\Account\\Users\\Names\\*"

And the problem was solved.

In the agent's log.The type has become the endpoint

{
  "_index": ".internal.alerts-security.alerts-default-000001",
  "_id": "13e2de3c0c0878adc85d4344675ed0a124a2c078c5fd412584eba40228d6557f",
  "_score": 1,
  "_source": {
    "kibana.alert.rule.execution.timestamp": "2026-04-24T09:07:07.773Z",
    "kibana.alert.start": "2026-04-24T09:07:07.773Z",
    "kibana.alert.last_detected": "2026-04-24T09:07:07.773Z",
    "kibana.version": "9.3.3",
    "kibana.alert.rule.parameters": {
      "description": "Создание локального пользователя Windows",
      "risk_score": 47,
      "severity": "medium",
      "note": "## Triage and analysis\n\n### Investigating User Account Creation\n\nAttackers may create new accounts (both local and domain) to maintain access to victim systems.\n\nThis rule identifies the usage of `net.exe` to create new accounts.\n\n#### Possible investigation steps\n\n- Investigate the process execution chain (parent process tree) for unknown processes. Examine their executable files for prevalence, whether they are located in expected locations, and if they are signed with valid digital signatures.\n- Identify the user account that performed the action and whether it should perform this kind of action.\n- Identify if the account was added to privileged groups or assigned special privileges after creation.\n- Investigate other alerts associated with the user/host during the past 48 hours.\n\n### False positive analysis\n\n- Account creation is a common administrative task, so there is a high chance of the activity being legitimate. Before investigating further, verify that this activity is not benign.\n\n### Related rules\n\n- Creation of a Hidden Local User Account - 2edc8076-291e-41e9-81e4-e3fcbc97ae5e\n- Windows User Account Creation - 38e17753-f581-4644-84da-0d60a8318694\n\n### Response and remediation\n\n- Initiate the incident response process based on the outcome of the triage.\n- Isolate the involved host to prevent further post-compromise behavior.\n- Delete the created account.\n- Investigate credential exposure on systems compromised or used by the attacker to ensure all compromised accounts are identified. Reset passwords for these accounts and other potentially compromised credentials, such as email, business systems, and web services.\n- Determine the initial vector abused by the attacker and take action to prevent reinfection through the same vector.\n- Using the incident response data, update logging and audit policies to improve the mean time to detect (MTTD) and the mean time to respond (MTTR).\n",
      "license": "Elastic License v2",
      "meta": {
        "kibana_siem_app_url": ""
      },
      "timestamp_override": "event.ingested",
      "timestamp_override_fallback_disabled": false,
      "author": [
        "Elastic"
      ],
      "false_positives": [],
      "from": "now-5m",
      "rule_id": "2177886d-b09c-4b7d-a001-e4e205b1e3aa",
      "max_signals": 100,
      "risk_score_mapping": [],
      "severity_mapping": [],
      "threat": [
        {
          "framework": "MITRE ATT&CK",
          "tactic": {
            "id": "TA0003",
            "name": "Persistence",
            "reference": "https://attack.mitre.org/tactics/TA0003/"
          },
          "technique": [
            {
              "id": "T1136",
              "name": "Create Account",
              "reference": "https://attack.mitre.org/techniques/T1136/",
              "subtechnique": [
                {
                  "id": "T1136.001",
                  "name": "Local Account",
                  "reference": "https://attack.mitre.org/techniques/T1136/001/"
                },
                {
                  "id": "T1136.002",
                  "name": "Domain Account",
                  "reference": "https://attack.mitre.org/techniques/T1136/002/"
                }
              ]
            }
          ]
        }
      ],
      "to": "now",
      "references": [],
      "version": 315,
      "exceptions_list": [],
      "immutable": false,
      "rule_source": {
        "type": "internal"
      },
      "related_integrations": [
        {
          "package": "endpoint",
          "version": "^8.2.0"
        },
        {
          "package": "windows",
          "version": "^3.0.0"
        },
        {
          "package": "system",
          "version": "^2.0.0"
        }
      ],
      "required_fields": [
        {
          "name": "event.type",
          "type": "keyword",
          "ecs": true
        },
        {
          "name": "host.os.type",
          "type": "keyword",
          "ecs": true
        },
        {
          "name": "process.args",
          "type": "keyword",
          "ecs": true
        },
        {
          "name": "process.name",
          "type": "keyword",
          "ecs": true
        },
        {
          "name": "process.parent.name",
          "type": "keyword",
          "ecs": true
        },
        {
          "name": "host.id",
          "type": "keyword",
          "ecs": true
        }
      ],
      "response_actions": [
        {
          "params": {
            "command": "isolate",
            "comment": ""
          },
          "action_type_id": ".endpoint"
        }
      ],
      "setup": "",
      "type": "eql",
      "language": "eql",
      "index": [
        "logs-endpoint.events.*",
        "logs-*"
      ],
      "query": "registry where host.os.type == \"windows\" and\n  event.type == \"change\" and\n  registry.path : \"HKLM\\\\SAM\\\\SAM\\\\Domains\\\\Account\\\\Users\\\\Names\\\\*\"",
      "filters": []
    },
    "kibana.alert.rule.category": "Event Correlation Rule",
    "kibana.alert.rule.consumer": "siem",
    "kibana.alert.rule.execution.uuid": "f7f0297e-454e-454e-9d89-9cfca3b6a6aa",
    "kibana.alert.rule.name": "User Local Account Creation ",
    "kibana.alert.rule.producer": "siem",
    "kibana.alert.rule.revision": 16,
    "kibana.alert.rule.rule_type_id": "siem.eqlRule",
    "kibana.alert.rule.uuid": "2327186a-9789-4da0-8384-0ca77359f977",
    "kibana.space_ids": [
      "default"
    ],
    "kibana.alert.rule.tags": [
      "Domain: Endpoint",
      "OS: Windows",
      "Use Case: Threat Detection",
      "Tactic: Persistence",
      "Resources: Investigation Guide",
      "Data Source: Elastic Endgame",
      "Data Source: Elastic Defend",
      "Data Source: Windows Security Event Logs",
      "Data Source: Microsoft Defender for Endpoint",
      "Data Source: Sysmon",
      "Data Source: SentinelOne",
      "Data Source: Crowdstrike"
    ],
    "@timestamp": "2026-04-24T09:07:07.736Z",
    "registry": {
      "hive": "HKLM",
      "path": "HKLM\\SAM\\SAM\\Domains\\Account\\Users\\Names\\frekenbok\\",
      "value": "",
      "key": "SAM\\SAM\\Domains\\Account\\Users\\Names\\frekenbok"
    },
    "agent": {
      "id": "7adfff14-dbb9-47b9-9add-87370b6916f0",
      "type": "endpoint",
      "version": "9.3.3+build202604082258"
    },
    "process": {
      "Ext": {
        "code_signature": [
          {
            "thumbprint_sha256": "9bbde7210c366f12f75022f81f39bfb13547b2a32beb7b0e6959db964ad2e84e",
            "trusted": true,
            "subject_name": "Microsoft Windows Publisher",
            "exists": true,
            "status": "trusted"
          }
        ]
      },
      "code_signature": {
        "thumbprint_sha256": "9bbde7210c366f12f75022f81f39bfb13547b2a32beb7b0e6959db964ad2e84e",
        "trusted": true,
        "subject_name": "Microsoft Windows Publisher",
        "exists": true,
        "status": "trusted"
      },
      "name": "lsass.exe",
      "pid": 696,
      "entity_id": "YthRPn2Z/rQo2Y+rFniIoQ",
      "executable": "C:\\Windows\\System32\\lsass.exe"
    },
    "ecs": {
      "version": "8.10.0"
    },
    "data_stream": {
      "namespace": "default",
      "type": "logs",
      "dataset": "endpoint.events.registry"
    },
    "elastic": {
      "agent": {
        "id": "7adfff14-dbb9-47b9-9add-87370b6916f0"
      }
    },
    "host": {
      "os": {
        "type": "windows"
      },
      "name": "win10-22h2-dj",
      "id": "370dd72e-e35f-4d3f-ad23-9e170365efc8",
      "risk": {
        "calculated_level": "Low",
        "calculated_score_norm": 34.245743
      }
    },
    "event": {
      "agent_id_status": "verified",
      "sequence": 40059,
      "ingested": "2026-04-24T09:06:32Z",
      "created": "2026-04-24T09:06:00.9401315Z",
      "module": "endpoint",
      "action": [
        "modification"
      ],
      "id": "OSg7YDuGvzD8gsik++++jySe",
      "category": [
        "registry"
      ],
      "type": [
        "change"
      ],
      "dataset": "endpoint.events.registry",
      "outcome": "unknown"
    },
    "message": "Endpoint registry event",
    "user": {
      "domain": "NT AUTHORITY",
      "name": "SYSTEM",
      "id": "S-1-5-18"
    },
    "kibana.alert.original_data_stream.namespace": "default",
    "kibana.alert.original_data_stream.type": "logs",
    "kibana.alert.original_data_stream.dataset": "endpoint.events.registry",
    "kibana.alert.original_event.agent_id_status": "verified",
    "kibana.alert.original_event.sequence": 40059,
    "kibana.alert.original_event.ingested": "2026-04-24T09:06:32Z",
    "kibana.alert.original_event.created": "2026-04-24T09:06:00.9401315Z",
    "kibana.alert.original_event.kind": "event",
    "kibana.alert.original_event.module": "endpoint",
    "kibana.alert.original_event.action": [
      "modification"
    ],
    "kibana.alert.original_event.id": "OSg7YDuGvzD8gsik++++jySe",
    "kibana.alert.original_event.category": [
      "registry"
    ],
    "kibana.alert.original_event.type": [
      "change"
    ],
    "kibana.alert.original_event.dataset": "endpoint.events.registry",
    "kibana.alert.original_event.outcome": "unknown",
    "event.kind": "signal",
    "kibana.alert.original_time": "2026-04-24T09:06:00.930Z",
    "kibana.alert.ancestors": [
      {
        "id": "hNS9vp0B_cX6tKqOog3Z",
        "type": "event",
        "index": ".ds-logs-endpoint.events.registry-default-2026.04.15-000001",
        "depth": 0
      }
    ],
    "kibana.alert.status": "active",
    "kibana.alert.workflow_status": "open",
    "kibana.alert.depth": 1,
    "kibana.alert.reason": "registry event with process lsass.exe, by SYSTEM on win10-22h2-dj created medium alert User Local Account Creation .",
    "kibana.alert.severity": "medium",
    "kibana.alert.risk_score": 47,
    "kibana.alert.rule.actions": [],
    "kibana.alert.rule.author": [
      "Elastic"
    ],
    "kibana.alert.rule.created_at": "2026-04-20T12:51:36.471Z",
    "kibana.alert.rule.created_by": "elastic",
    "kibana.alert.rule.description": "Создание локального пользователя Windows",
    "kibana.alert.rule.enabled": true,
    "kibana.alert.rule.exceptions_list": [],
    "kibana.alert.rule.false_positives": [],
    "kibana.alert.rule.from": "now-5m",
    "kibana.alert.rule.immutable": false,
    "kibana.alert.rule.interval": "1m",
    "kibana.alert.rule.indices": [
      "logs-endpoint.events.*",
      "logs-*"
    ],
    "kibana.alert.rule.license": "Elastic License v2",
    "kibana.alert.rule.max_signals": 100,
    "kibana.alert.rule.note": "## Triage and analysis\n\n### Investigating User Account Creation\n\nAttackers may create new accounts (both local and domain) to maintain access to victim systems.\n\nThis rule identifies the usage of `net.exe` to create new accounts.\n\n#### Possible investigation steps\n\n- Investigate the process execution chain (parent process tree) for unknown processes. Examine their executable files for prevalence, whether they are located in expected locations, and if they are signed with valid digital signatures.\n- Identify the user account that performed the action and whether it should perform this kind of action.\n- Identify if the account was added to privileged groups or assigned special privileges after creation.\n- Investigate other alerts associated with the user/host during the past 48 hours.\n\n### False positive analysis\n\n- Account creation is a common administrative task, so there is a high chance of the activity being legitimate. Before investigating further, verify that this activity is not benign.\n\n### Related rules\n\n- Creation of a Hidden Local User Account - 2edc8076-291e-41e9-81e4-e3fcbc97ae5e\n- Windows User Account Creation - 38e17753-f581-4644-84da-0d60a8318694\n\n### Response and remediation\n\n- Initiate the incident response process based on the outcome of the triage.\n- Isolate the involved host to prevent further post-compromise behavior.\n- Delete the created account.\n- Investigate credential exposure on systems compromised or used by the attacker to ensure all compromised accounts are identified. Reset passwords for these accounts and other potentially compromised credentials, such as email, business systems, and web services.\n- Determine the initial vector abused by the attacker and take action to prevent reinfection through the same vector.\n- Using the incident response data, update logging and audit policies to improve the mean time to detect (MTTD) and the mean time to respond (MTTR).\n",
    "kibana.alert.rule.references": [],
    "kibana.alert.rule.risk_score_mapping": [],
    "kibana.alert.rule.rule_id": "2177886d-b09c-4b7d-a001-e4e205b1e3aa",
    "kibana.alert.rule.severity_mapping": [],
    "kibana.alert.rule.threat": [
      {
        "framework": "MITRE ATT&CK",
        "tactic": {
          "id": "TA0003",
          "name": "Persistence",
          "reference": "https://attack.mitre.org/tactics/TA0003/"
        },
        "technique": [
          {
            "id": "T1136",
            "name": "Create Account",
            "reference": "https://attack.mitre.org/techniques/T1136/",
            "subtechnique": [
              {
                "id": "T1136.001",
                "name": "Local Account",
                "reference": "https://attack.mitre.org/techniques/T1136/001/"
              },
              {
                "id": "T1136.002",
                "name": "Domain Account",
                "reference": "https://attack.mitre.org/techniques/T1136/002/"
              }
            ]
          }
        ]
      }
    ],
    "kibana.alert.rule.timestamp_override": "event.ingested",
    "kibana.alert.rule.to": "now",
    "kibana.alert.rule.type": "eql",
    "kibana.alert.rule.updated_at": "2026-04-24T09:04:53.652Z",
    "kibana.alert.rule.updated_by": "elastic",
    "kibana.alert.rule.version": 315,
    "kibana.alert.uuid": "13e2de3c0c0878adc85d4344675ed0a124a2c078c5fd412584eba40228d6557f",
    "kibana.alert.workflow_tags": [],
    "kibana.alert.workflow_assignee_ids": [],
    "kibana.alert.rule.meta.kibana_siem_app_url": "",
    "kibana.alert.rule.risk_score": 47,
    "kibana.alert.rule.severity": "medium",
    "kibana.alert.intended_timestamp": "2026-04-24T09:07:07.736Z",
    "kibana.alert.rule.execution.type": "scheduled"
  },
  "fields": {
    "kibana.alert.severity": [
      "medium"
    ],
    "kibana.alert.rule.updated_by": [
      "elastic"
    ],
    "signal.ancestors.depth": [
      0
    ],
    "event.category": [
      "registry"
    ],
    "host.risk.calculated_score_norm": [
      34.245743
    ],
    "kibana.alert.rule.tags": [
      "Domain: Endpoint",
      "OS: Windows",
      "Use Case: Threat Detection",
      "Tactic: Persistence",
      "Resources: Investigation Guide",
      "Data Source: Elastic Endgame",
      "Data Source: Elastic Defend",
      "Data Source: Windows Security Event Logs",
      "Data Source: Microsoft Defender for Endpoint",
      "Data Source: Sysmon",
      "Data Source: SentinelOne",
      "Data Source: Crowdstrike"
    ],
    "signal.original_event.created": [
      "2026-04-24T09:06:00.940Z"
    ],
    "process.code_signature.exists": [
      true
    ],
    "signal.rule.threat.technique.subtechnique.id": [
      "T1136.001",
      "T1136.002"
    ],
    "kibana.alert.reason.text": [
      "registry event with process lsass.exe, by SYSTEM on win10-22h2-dj created medium alert User Local Account Creation ."
    ],
    "elastic.agent.id": [
      "7adfff14-dbb9-47b9-9add-87370b6916f0"
    ],
    "kibana.alert.rule.threat.technique.id": [
      "T1136"
    ],
    "kibana.alert.ancestors.depth": [
      0
    ],
    "signal.rule.enabled": [
      "true"
    ],
    "signal.rule.max_signals": [
      100
    ],
    "kibana.alert.risk_score": [
      47
    ],
    "signal.rule.updated_at": [
      "2026-04-24T09:04:53.652Z"
    ],
    "kibana.alert.rule.threat.technique.subtechnique.name": [
      "Local Account",
      "Domain Account"
    ],
    "kibana.alert.rule.threat.technique.subtechnique.reference": [
      "https://attack.mitre.org/techniques/T1136/001/",
      "https://attack.mitre.org/techniques/T1136/002/"
    ],
    "event.agent_id_status": [
      "verified"
    ],
    "kibana.alert.original_event.id": [
      "OSg7YDuGvzD8gsik++++jySe"
    ],
    "event.outcome": [
      "unknown"
    ],
    "registry.path": [
      "HKLM\\SAM\\SAM\\Domains\\Account\\Users\\Names\\frekenbok\\"
    ],
    "host.os.type": [
      "windows"
    ],
    "user.id": [
      "S-1-5-18"
    ],
    "process.Ext.code_signature.thumbprint_sha256": [
      "9bbde7210c366f12f75022f81f39bfb13547b2a32beb7b0e6959db964ad2e84e"
    ],
    "kibana.alert.original_event.module": [
      "endpoint"
    ],
    "kibana.alert.rule.interval": [
      "1m"
    ],
    "kibana.alert.rule.type": [
      "eql"
    ],
    "signal.original_event.sequence": [
      40059
    ],
    "signal.rule.threat.technique.subtechnique.name": [
      "Local Account",
      "Domain Account"
    ],
    "kibana.alert.start": [
      "2026-04-24T09:07:07.773Z"
    ],
    "kibana.alert.rule.immutable": [
      "false"
    ],
    "process.Ext.code_signature.status": [
      "trusted"
    ],
    "kibana.alert.original_event.type": [
      "change"
    ],
    "agent.id": [
      "7adfff14-dbb9-47b9-9add-87370b6916f0"
    ],
    "signal.original_event.module": [
      "endpoint"
    ],
    "signal.rule.from": [
      "now-5m"
    ],
    "kibana.alert.rule.enabled": [
      "true"
    ],
    "kibana.alert.rule.version": [
      "315"
    ],
    "kibana.alert.ancestors.type": [
      "event"
    ],
    "signal.ancestors.index": [
      ".ds-logs-endpoint.events.registry-default-2026.04.15-000001"
    ],
    "user.name": [
      "SYSTEM"
    ],
    "signal.original_event.outcome": [
      "unknown"
    ],
    "kibana.alert.original_data_stream.dataset": [
      "endpoint.events.registry"
    ],
    "process.entity_id": [
      "YthRPn2Z/rQo2Y+rFniIoQ"
    ],
    "agent.type": [
      "endpoint"
    ],
    "process.executable.text": [
      "C:\\Windows\\System32\\lsass.exe"
    ],
    "signal.original_event.category": [
      "registry"
    ],
    "signal.original_event.id": [
      "OSg7YDuGvzD8gsik++++jySe"
    ],
    "signal.rule.threat.framework": [
      "MITRE ATT&CK"
    ],
    "user.domain": [
      "NT AUTHORITY"
    ],
    "host.id": [
      "370dd72e-e35f-4d3f-ad23-9e170365efc8"
    ],
    "process.Ext.code_signature.subject_name": [
      "Microsoft Windows Publisher"
    ],
    "signal.original_event.type": [
      "change"
    ],
    "kibana.alert.rule.note": [
      "## Triage and analysis\n\n### Investigating User Account Creation\n\nAttackers may create new accounts (both local and domain) to maintain access to victim systems.\n\nThis rule identifies the usage of `net.exe` to create new accounts.\n\n#### Possible investigation steps\n\n- Investigate the process execution chain (parent process tree) for unknown processes. Examine their executable files for prevalence, whether they are located in expected locations, and if they are signed with valid digital signatures.\n- Identify the user account that performed the action and whether it should perform this kind of action.\n- Identify if the account was added to privileged groups or assigned special privileges after creation.\n- Investigate other alerts associated with the user/host during the past 48 hours.\n\n### False positive analysis\n\n- Account creation is a common administrative task, so there is a high chance of the activity being legitimate. Before investigating further, verify that this activity is not benign.\n\n### Related rules\n\n- Creation of a Hidden Local User Account - 2edc8076-291e-41e9-81e4-e3fcbc97ae5e\n- Windows User Account Creation - 38e17753-f581-4644-84da-0d60a8318694\n\n### Response and remediation\n\n- Initiate the incident response process based on the outcome of the triage.\n- Isolate the involved host to prevent further post-compromise behavior.\n- Delete the created account.\n- Investigate credential exposure on systems compromised or used by the attacker to ensure all compromised accounts are identified. Reset passwords for these accounts and other potentially compromised credentials, such as email, business systems, and web services.\n- Determine the initial vector abused by the attacker and take action to prevent reinfection through the same vector.\n- Using the incident response data, update logging and audit policies to improve the mean time to detect (MTTD) and the mean time to respond (MTTR).\n"
    ],
    "kibana.alert.rule.max_signals": [
      100
    ],
    "signal.rule.author": [
      "Elastic"
    ],
    "kibana.alert.rule.risk_score": [
      47
    ],
    "process.code_signature.status": [
      "trusted"
    ],
    "signal.original_event.dataset": [
      "endpoint.events.registry"
    ],
    "signal.rule.threat.technique.id": [
      "T1136"
    ],
    "kibana.alert.rule.consumer": [
      "siem"
    ],
    "kibana.alert.rule.indices": [
      "logs-endpoint.events.*",
      "logs-*"
    ],
    "kibana.alert.rule.category": [
      "Event Correlation Rule"
    ],
    "event.action": [
      "modification"
    ],
    "event.ingested": [
      "2026-04-24T09:06:32.000Z"
    ],
    "signal.rule.threat.technique.subtechnique.reference": [
      "https://attack.mitre.org/techniques/T1136/001/",
      "https://attack.mitre.org/techniques/T1136/002/"
    ],
    "@timestamp": [
      "2026-04-24T09:07:07.736Z"
    ],
    "kibana.alert.original_event.action": [
      "modification"
    ],
    "signal.rule.updated_by": [
      "elastic"
    ],
    "kibana.alert.intended_timestamp": [
      "2026-04-24T09:07:07.736Z"
    ],
    "kibana.alert.rule.severity": [
      "medium"
    ],
    "kibana.alert.original_event.agent_id_status": [
      "verified"
    ],
    "data_stream.dataset": [
      "endpoint.events.registry"
    ],
    "signal.rule.timestamp_override": [
      "event.ingested"
    ],
    "host.risk.calculated_level": [
      "Low"
    ],
    "kibana.alert.rule.execution.timestamp": [
      "2026-04-24T09:07:07.773Z"
    ],
    "signal.rule.threat.technique.reference": [
      "https://attack.mitre.org/techniques/T1136/"
    ],
    "kibana.alert.rule.execution.uuid": [
      "f7f0297e-454e-454e-9d89-9cfca3b6a6aa"
    ],
    "kibana.alert.uuid": [
      "13e2de3c0c0878adc85d4344675ed0a124a2c078c5fd412584eba40228d6557f"
    ],
    "signal.rule.note": [
      "## Triage and analysis\n\n### Investigating User Account Creation\n\nAttackers may create new accounts (both local and domain) to maintain access to victim systems.\n\nThis rule identifies the usage of `net.exe` to create new accounts.\n\n#### Possible investigation steps\n\n- Investigate the process execution chain (parent process tree) for unknown processes. Examine their executable files for prevalence, whether they are located in expected locations, and if they are signed with valid digital signatures.\n- Identify the user account that performed the action and whether it should perform this kind of action.\n- Identify if the account was added to privileged groups or assigned special privileges after creation.\n- Investigate other alerts associated with the user/host during the past 48 hours.\n\n### False positive analysis\n\n- Account creation is a common administrative task, so there is a high chance of the activity being legitimate. Before investigating further, verify that this activity is not benign.\n\n### Related rules\n\n- Creation of a Hidden Local User Account - 2edc8076-291e-41e9-81e4-e3fcbc97ae5e\n- Windows User Account Creation - 38e17753-f581-4644-84da-0d60a8318694\n\n### Response and remediation\n\n- Initiate the incident response process based on the outcome of the triage.\n- Isolate the involved host to prevent further post-compromise behavior.\n- Delete the created account.\n- Investigate credential exposure on systems compromised or used by the attacker to ensure all compromised accounts are identified. Reset passwords for these accounts and other potentially compromised credentials, such as email, business systems, and web services.\n- Determine the initial vector abused by the attacker and take action to prevent reinfection through the same vector.\n- Using the incident response data, update logging and audit policies to improve the mean time to detect (MTTD) and the mean time to respond (MTTR).\n"
    ],
    "kibana.alert.rule.meta.kibana_siem_app_url": [
      ""
    ],
    "kibana.version": [
      "9.3.3"
    ],
    "event.id": [
      "OSg7YDuGvzD8gsik++++jySe"
    ],
    "signal.rule.threat.technique.name": [
      "Create Account"
    ],
    "signal.rule.license": [
      "Elastic License v2"
    ],
    "signal.ancestors.type": [
      "event"
    ],
    "kibana.alert.rule.rule_id": [
      "2177886d-b09c-4b7d-a001-e4e205b1e3aa"
    ],
    "registry.value": [
      ""
    ],
    "user.name.text": [
      "SYSTEM"
    ],
    "signal.rule.type": [
      "eql"
    ],
    "kibana.alert.ancestors.id": [
      "hNS9vp0B_cX6tKqOog3Z"
    ],
    "process.name.text": [
      "lsass.exe"
    ],
    "kibana.alert.original_data_stream.namespace": [
      "default"
    ],
    "kibana.alert.rule.description": [
      "Создание локального пользователя Windows"
    ],
    "process.pid": [
      696
    ],
    "kibana.alert.rule.producer": [
      "siem"
    ],
    "kibana.alert.rule.to": [
      "now"
    ],
    "signal.rule.created_by": [
      "elastic"
    ],
    "signal.rule.interval": [
      "1m"
    ],
    "kibana.alert.rule.created_by": [
      "elastic"
    ],
    "kibana.alert.original_event.ingested": [
      "2026-04-24T09:06:32.000Z"
    ],
    "kibana.alert.rule.timestamp_override": [
      "event.ingested"
    ],
    "registry.hive": [
      "HKLM"
    ],
    "signal.rule.id": [
      "2327186a-9789-4da0-8384-0ca77359f977"
    ],
    "process.code_signature.subject_name": [
      "Microsoft Windows Publisher"
    ],
    "signal.reason": [
      "registry event with process lsass.exe, by SYSTEM on win10-22h2-dj created medium alert User Local Account Creation ."
    ],
    "signal.rule.risk_score": [
      47
    ],
    "registry.key": [
      "SAM\\SAM\\Domains\\Account\\Users\\Names\\frekenbok"
    ],
    "kibana.alert.rule.name": [
      "User Local Account Creation "
    ],
    "host.name": [
      "win10-22h2-dj"
    ],
    "kibana.alert.rule.threat.technique.reference": [
      "https://attack.mitre.org/techniques/T1136/"
    ],
    "signal.status": [
      "open"
    ],
    "event.kind": [
      "signal"
    ],
    "process.code_signature.thumbprint_sha256": [
      "9bbde7210c366f12f75022f81f39bfb13547b2a32beb7b0e6959db964ad2e84e"
    ],
    "process.code_signature.trusted": [
      true
    ],
    "signal.rule.created_at": [
      "2026-04-20T12:51:36.471Z"
    ],
    "signal.rule.tags": [
      "Domain: Endpoint",
      "OS: Windows",
      "Use Case: Threat Detection",
      "Tactic: Persistence",
      "Resources: Investigation Guide",
      "Data Source: Elastic Endgame",
      "Data Source: Elastic Defend",
      "Data Source: Windows Security Event Logs",
      "Data Source: Microsoft Defender for Endpoint",
      "Data Source: Sysmon",
      "Data Source: SentinelOne",
      "Data Source: Crowdstrike"
    ],
    "kibana.alert.workflow_status": [
      "open"
    ],
    "kibana.alert.original_event.created": [
      "2026-04-24T09:06:00.940Z"
    ],
    "kibana.alert.rule.threat.tactic.name": [
      "Persistence"
    ],
    "kibana.alert.rule.uuid": [
      "2327186a-9789-4da0-8384-0ca77359f977"
    ],
    "kibana.alert.original_event.category": [
      "registry"
    ],
    "kibana.alert.reason": [
      "registry event with process lsass.exe, by SYSTEM on win10-22h2-dj created medium alert User Local Account Creation ."
    ],
    "signal.rule.threat.tactic.id": [
      "TA0003"
    ],
    "data_stream.type": [
      "logs"
    ],
    "signal.ancestors.id": [
      "hNS9vp0B_cX6tKqOog3Z"
    ],
    "signal.original_time": [
      "2026-04-24T09:06:00.930Z"
    ],
    "process.name": [
      "lsass.exe"
    ],
    "ecs.version": [
      "8.10.0"
    ],
    "signal.rule.severity": [
      "medium"
    ],
    "kibana.alert.ancestors.index": [
      ".ds-logs-endpoint.events.registry-default-2026.04.15-000001"
    ],
    "event.created": [
      "2026-04-24T09:06:00.940Z"
    ],
    "process.Ext.code_signature.trusted": [
      true
    ],
    "agent.version": [
      "9.3.3+build202604082258"
    ],
    "kibana.alert.depth": [
      1
    ],
    "kibana.alert.rule.from": [
      "now-5m"
    ],
    "kibana.alert.rule.parameters": [
      {
        "note": "## Triage and analysis\n\n### Investigating User Account Creation\n\nAttackers may create new accounts (both local and domain) to maintain access to victim systems.\n\nThis rule identifies the usage of `net.exe` to create new accounts.\n\n#### Possible investigation steps\n\n- Investigate the process execution chain (parent process tree) for unknown processes. Examine their executable files for prevalence, whether they are located in expected locations, and if they are signed with valid digital signatures.\n- Identify the user account that performed the action and whether it should perform this kind of action.\n- Identify if the account was added to privileged groups or assigned special privileges after creation.\n- Investigate other alerts associated with the user/host during the past 48 hours.\n\n### False positive analysis\n\n- Account creation is a common administrative task, so there is a high chance of the activity being legitimate. Before investigating further, verify that this activity is not benign.\n\n### Related rules\n\n- Creation of a Hidden Local User Account - 2edc8076-291e-41e9-81e4-e3fcbc97ae5e\n- Windows User Account Creation - 38e17753-f581-4644-84da-0d60a8318694\n\n### Response and remediation\n\n- Initiate the incident response process based on the outcome of the triage.\n- Isolate the involved host to prevent further post-compromise behavior.\n- Delete the created account.\n- Investigate credential exposure on systems compromised or used by the attacker to ensure all compromised accounts are identified. Reset passwords for these accounts and other potentially compromised credentials, such as email, business systems, and web services.\n- Determine the initial vector abused by the attacker and take action to prevent reinfection through the same vector.\n- Using the incident response data, update logging and audit policies to improve the mean time to detect (MTTD) and the mean time to respond (MTTR).\n",
        "description": "Создание локального пользователя Windows",
        "language": "eql",
        "type": "eql",
        "timestamp_override_fallback_disabled": false,
        "timestamp_override": "event.ingested",
        "from": "now-5m",
        "severity": "medium",
        "max_signals": 100,
        "rule_source": {
          "type": "internal"
        },
        "risk_score": 47,
        "author": "Elastic",
        "query": "registry where host.os.type == \"windows\" and\n  event.type == \"change\" and\n  registry.path : \"HKLM\\\\SAM\\\\SAM\\\\Domains\\\\Account\\\\Users\\\\Names\\\\*\"",
        "index": [
          "logs-endpoint.events.*",
          "logs-*"
        ],
        "response_actions": {
          "params": {
            "command": "isolate",
            "comment": ""
          },
          "action_type_id": ".endpoint"
        },
        "version": 315,
        "rule_id": "2177886d-b09c-4b7d-a001-e4e205b1e3aa",
        "license": "Elastic License v2",
        "required_fields": [
          {
            "name": "event.type",
            "type": "keyword",
            "ecs": true
          },
          {
            "name": "host.os.type",
            "type": "keyword",
            "ecs": true
          },
          {
            "name": "process.args",
            "type": "keyword",
            "ecs": true
          },
          {
            "name": "process.name",
            "type": "keyword",
            "ecs": true
          },
          {
            "name": "process.parent.name",
            "type": "keyword",
            "ecs": true
          },
          {
            "name": "host.id",
            "type": "keyword",
            "ecs": true
          }
        ],
        "immutable": false,
        "related_integrations": [
          {
            "package": "endpoint",
            "version": "^8.2.0"
          },
          {
            "package": "windows",
            "version": "^3.0.0"
          },
          {
            "package": "system",
            "version": "^2.0.0"
          }
        ],
        "meta": {
          "kibana_siem_app_url": ""
        },
        "setup": "",
        "threat": {
          "framework": "MITRE ATT&CK",
          "tactic": {
            "id": "TA0003",
            "name": "Persistence",
            "reference": "https://attack.mitre.org/tactics/TA0003/"
          },
          "technique": [
            {
              "id": "T1136",
              "name": "Create Account",
              "reference": "https://attack.mitre.org/techniques/T1136/",
              "subtechnique": [
                {
                  "id": "T1136.001",
                  "name": "Local Account",
                  "reference": "https://attack.mitre.org/techniques/T1136/001/"
                },
                {
                  "id": "T1136.002",
                  "name": "Domain Account",
                  "reference": "https://attack.mitre.org/techniques/T1136/002/"
                }
              ]
            }
          ]
        },
        "to": "now"
      }
    ],
    "kibana.alert.rule.revision": [
      16
    ],
    "kibana.alert.rule.threat.tactic.id": [
      "TA0003"
    ],
    "signal.rule.version": [
      "315"
    ],
    "signal.original_event.kind": [
      "event"
    ],
    "kibana.alert.rule.threat.technique.name": [
      "Create Account"
    ],
    "kibana.alert.status": [
      "active"
    ],
    "kibana.alert.last_detected": [
      "2026-04-24T09:07:07.773Z"
    ],
    "kibana.alert.original_event.dataset": [
      "endpoint.events.registry"
    ],
    "signal.depth": [
      1
    ],
    "signal.rule.immutable": [
      "false"
    ],
    "event.sequence": [
      40059
    ],
    "kibana.alert.rule.rule_type_id": [
      "siem.eqlRule"
    ],
    "signal.rule.name": [
      "User Local Account Creation "
    ],
    "event.module": [
      "endpoint"
    ],
    "signal.rule.rule_id": [
      "2177886d-b09c-4b7d-a001-e4e205b1e3aa"
    ],
    "signal.rule.threat.tactic.reference": [
      "https://attack.mitre.org/tactics/TA0003/"
    ],
    "kibana.alert.rule.license": [
      "Elastic License v2"
    ],
    "kibana.alert.rule.threat.technique.subtechnique.id": [
      "T1136.001",
      "T1136.002"
    ],
    "kibana.alert.original_event.kind": [
      "event"
    ],
    "process.executable": [
      "C:\\Windows\\System32\\lsass.exe"
    ],
    "signal.rule.threat.tactic.name": [
      "Persistence"
    ],
    "kibana.alert.rule.threat.framework": [
      "MITRE ATT&CK"
    ],
    "kibana.alert.rule.updated_at": [
      "2026-04-24T09:04:53.652Z"
    ],
    "signal.rule.description": [
      "Создание локального пользователя Windows"
    ],
    "data_stream.namespace": [
      "default"
    ],
    "kibana.alert.rule.author": [
      "Elastic"
    ],
    "message": [
      "Endpoint registry event"
    ],
    "process.Ext.code_signature.exists": [
      true
    ],
    "kibana.alert.original_event.outcome": [
      "unknown"
    ],
    "kibana.alert.original_event.sequence": [
      40059
    ],
    "kibana.alert.rule.threat.tactic.reference": [
      "https://attack.mitre.org/tactics/TA0003/"
    ],
    "signal.original_event.action": [
      "modification"
    ],
    "kibana.alert.original_data_stream.type": [
      "logs"
    ],
    "kibana.alert.rule.created_at": [
      "2026-04-20T12:51:36.471Z"
    ],
    "signal.rule.to": [
      "now"
    ],
    "event.type": [
      "change"
    ],
    "kibana.space_ids": [
      "default"
    ],
    "kibana.alert.rule.execution.type": [
      "scheduled"
    ],
    "event.dataset": [
      "endpoint.events.registry"
    ],
    "kibana.alert.original_time": [
      "2026-04-24T09:06:00.930Z"
    ]
  }
}