There is no setting to disable SSL verification in watcher http input

Hi Team,
I am using elasticsearch watcher http input to read list of values. but when I configured its showing

    "type": "s_s_l_handshake_exception",
        "reason": "PKIX path building failed: unable to find valid certification path to requested target",

I search on documentation page, I didn't see any option to disable SSL cert verification.

Is there any other way to avoid this error or setting in watcher input?


Not sure if this applies to watcher but after reviewing this issue that ended up in this PR, at least for alerting actions there is a xpack.actions.customHostSettings that allows to disable certificate verification for defined hosts.

Check the Action Settings section at this documentation page

Another option I think would be to configure your kibana server to include the (self-signed?) certificate form your destination, but I may be wrong here.

Hope it helps!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.