Threadpool.bulk.size key ignored

Hey there,
using an old ES version (2.x) I was trying to use a custom configuration regarding threadpool.
currently, nodes have 8 processors. This value is correctly recognized by ES but when I try to increase it, nothing happens.
I specified

threadpool.bulk.type: fixed
threadpool.bulk.size: 16

into every elasticsearch.yml file and then I have fully restarted the cluster.
I tried also to use the dynamic updates of cluster settings withoud any result.
The threadpool size is still capped to 8 and I got this log message:

requested thread pool size [16] for [bulk] is too large; setting to maximum [8] instead

The only way to get it is to specify

processor: 16

in the elasticsearch.yml but I would like to avoid this way. is this the only way to do that?
I saw also github issue. If this is correct, this scenario should be highlighted in the official doc (also the current 7.x).

Anyone can help or address me?

Yep, there's not a lot of point in having more process threads for a given pool than there is CPU threads. You're really just moving the problem elsewhere.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.