Tile Map no results


(Turboemu) #1

Hi, I am storing lat long values in Elasticsearch and attempting to view these on a Tile Map. I have added a mapping for my geo_point field and added the data to the index. However Kibana shows 'No results found'.

I'm using fresh installs of Elasticsearch v2.3.1, Kibana v4.5.0 on Windows 7

My mappings are:

{
   "mappings":{
      "_default_":{
         "dynamic_templates":[
            {
               "default":{
                  "match":"*",
                  "match_mapping_type":"string",
                  "mapping":{
                     "type":"string",
                     "fields":{
                        "raw":{
                           "type":"string",
                           "index":"not_analyzed"
                        }
                     }
                  }
               }
            }
         ]
      },
      "geoloc":{
         "properties":{
            "coords":{
               "type":"geo_point"
            }
         }
      }
   }
}

A slightly boiled down example document is:

{
   "order_id":"Test",
   "date":"2015-09-26",
   "geoloc":{
      "coords":[
         "33.932169964868",
         "-3.16950540340576"
      ]
   },
   "contentId":1111111,
   "reportTitle":"Test Title",
   "type":"62",
   "ids":"58;42",
   "values":[
      "Test1",
      "Test2"
   ],
   "status":"COMPLETE",
   "typeValue":[
      "Report"
   ]
}

Kibana recognises the 'coords' property as a geo_point but does not find any documents (I do have documents in the given date range with geo_point values). I have tried various combinations of nesting the geo_point property at different levels in my document; different mappings to explicitly state lat_lon; adding geohash to my mapping and values; pairing down my mappings to just the geo_point part. None of which change the behaviour.

I have noticed that the request body shown on the Tile Map page has "size": 0 set. Is this correct? I understand size can be set to 0 when aggregations are returned rather than results. But it stands out when I am not seeing any results.


(Meenal Luktuke) #2

When I faced the similar issue, my problem was - type mismatch in logstash configuration and ES mapping definition. Can you try to get mappings for the index and verify that geoloc is mapped correctly while posting data into ES? That would be the only problem if you're not getting any results.


(Lee Drengenberg) #3

Hi Turboemu,

I found an issue with a similar symptom. If you'll look at this; https://github.com/elastic/kibana/issues/6697 and see if it gives you any clues. And I'll keep digging.

Regards,
Lee


(Turboemu) #4

Thank you both for your time! As both your answers hinted at, I had incorrectly setup the mappings.

I was PUTing documents into the index e.g. http://localhost:9200/commerce/order/1 instead of http://localhost:9200/commerce/geoloc/1 which my mapping suggested would be the case.

This was a misinterpretation of the documentation. Thank you both for the advice and I hope you didn't spend too much time digging.


(Shriram Bharath) #5

How do i change it, pls help here


(Meenal Luktuke) #6

What do you want to change?

If you have created a logstash config for type:test, make sure your ES mapping is like this: PUT /index/test
{//All definitions for mappings
}

That should solve your problem. Let me know if this is not clear, will post an example.


(Shriram Bharath) #7

I fixed it, thanks a lot


(system) #8