Tilemap visualisation - place markers off-grid (use geocentroid) - not working - uncheck by default


when doing tilemap visualisations the "place markers off-grid (use geocentroid)" is checked by default (as described in the Kibana documentation).

I would like to have this unchecked by default because it is not showing anything and furthermore it is not the right option for our usecase.

Is there a way to uncheck this box by default?


P.S. we're working on ELK stack 5.4

Sadly there is no option to change the default for that (you could add an Ehancement Request for it in the Kibana repo on Github). But I'd really like to know more about it not working, maybe we can fix that.

Hey Marius, thanks for the reply.

I will try to explain what happens. You also should know we run ELK stack 5.4 on a network that has no internet connection and we run our own wms server.

When we visualize a set of hits with "place markers off grid" we get essentially a blank overview map (watch the Geo Centroid legend showing "NaN - Nan") :

When we click on "Fit data bounds" the map zooms in and shows an area that looks like it has a white rectangle in the middle :

When we visualize the same set with "place markers off grid" UNchecked, we get the result we want (the legend is now showing the expected values) :

I hope this is of some help to you.

I pinged one of the developers on this, he will have a look at it. @thomasneirynck

hi @smyttie

can you open the spy panel (the little grey arrow near the bottom-left of the map), and share the request/responses, for both when you have the box checked and when you have the box unchecked?


Hi Thomas,

the screenshots you requested, twice the same result with 7 hits :

This is with 'place markers' checked, nothing useful on the map, but correct number of hits and the coordinates displayed in the spy window.

This one is with 'place markers' unchecked, showing what we want; except for the legend showing 'count 0-1'.

hi @smyttie

can you paste the request and responses?

there seems to be an issue with the formatting, judging from the top screenshot

Sorry Thomas, I'm not at that workplace anymore and cannot emulate the situation anymore.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.