Timeouts ignored in multisearch?


(Mike Sukmanowsky) #1

Hi all,

We're doing an analysis of our slow queries (via slowlog) and noticing that
any queries made with msearch seem to ignore the timeout parameter. We've
tried passing it three ways:

GET my_index/_msearch?timeout=100
{}
{big aggregation query}

and

GET my_index/_msearch
{"timeout": 100}
{big aggregation query}

and finally:

GET my_index/_msearch?timeout=100
{"timeout": 100}
{big aggregation query}

Multisearch results always return long after 100ms with "timed_out": false
indicating that they're ignoring our request here. This is very problematic
as we need certain aggregation queries to timeout if they're too greedy to
allow others to run.

Can anyone confirm if this is the case?

Mike

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b94c31a3-c57a-403b-8d70-a8c2a47682af%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2