Timestamp isn't Matching from what was imported into Elasticsearch


(Tim Schoffelman) #1

I imported my JSON into elasticsearch with the timestamp displaying in my _source not matching what is displaying in Kibana. Has anyone else ran into this?

Here's an example:


(Christian Dahlqvist) #2

All timestamps in Elasticsearch are in UTC, but Kibana will adjust this to the local timezone when displaying the data. It does however not modify the source, which should explain the discrepancy you are seeing.


(Tim Schoffelman) #3

Ah, gotcha. Thank you for the heads up on the difference between Elasticsearch vs Kibana.

This does throw people off when working with the data in the reports. Meaning, if we show all data for a week, Monday's info shows on Sunday. Is there a way to specify what the UTC offset is or am I better off going into Kibana's settings, adjusting the timezone from browser specific, to UTC-0? Or is there a different route altogether I should consider so that when people are looking at reports, Monday's data is displaying as Monday?


(Tim Schoffelman) #4

I see there's a setting in Management > Kibana > Advanced Settings called "Timezone for date formatting" that can be set to UTC. I changed this and it seemed to have resolved the issue.

If there's a better way to handle this let me know, otherwise, thank you again!


(Christian Dahlqvist) #5

No, that is what I was going to suggest as a workaround.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.