Timestamp


(Khoa Nguyen) #1

Here's my finding on the _timestamp field.

curl -XPOST 'localhost:9200/bam' -d '{
"mappings" : {
"default" : {
"_timestamp": { "enabled" : true }
}
}
}
}'

curl -XPOST 'localhost:9200/bam/bam/' -d '{
"bam" : "bam"
}'

curl 'localhost:9200/bam/_search?fields=_source,_timestamp&pretty'

{

"took" : 1,

"timed_out" : false,

"_shards" : {

"total" : 5,

"successful" : 5,

"failed" : 0

},

"hits" : {

"total" : 1,

"max_score" : 1.0,

"hits" : [ {

  "_index" : "bam",

  "_type" : "bam",

  "_id" : "DREzT5VFTe2aJQC5ZRQb2g",

  "_score" : 1.0, "_source" : {

"bam" : "bam"

}

} ]

}

}

curl -XPOST 'localhost:9200/bambam' -d '{
"mappings" : {
"default" : {
"_timestamp": { "enabled" : true, "store" : true }
}
}
}
}'

curl -XPOST 'localhost:9200/bambam/bambam/' -d '{
"bambam" : "bambam"
}'

curl 'localhost:9200/bambam/_search?fields=_source,_timestamp&pretty'

{

"took" : 1,

"timed_out" : false,

"_shards" : {

"total" : 5,

"successful" : 5,

"failed" : 0

},

"hits" : {

"total" : 1,

"max_score" : 1.0,

"hits" : [ {

  "_index" : "bambam",

  "_type" : "bambam",

  "_id" : "bDa7LxPBRQaPnoxj6R96dw",

  "_score" : 1.0, "_source" : {

"bambam" : "bambam"

},

  "fields" : {

    "_timestamp" : 1392089217844

  }

} ]

}

}

Is this what you're seeing?

I guess timestamp is being "stored" somewhere in order for facet and query
to work. But it is unexpected that without store: true, that no timestamps
are returned in result.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0b1dff20-aacd-405c-8db8-ba19295a8f89%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Why it's unexpected?

If a field is not stored, you can not retrieve it. What's wrong with that?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 févr. 2014 à 04:34, Khoa Nguyen huu.khoa.nguyen@gmail.com a écrit :

Here's my finding on the _timestamp field.

curl -XPOST 'localhost:9200/bam' -d '{
"mappings" : {
"default" : {
"_timestamp": { "enabled" : true }
}
}
}
}'

curl -XPOST 'localhost:9200/bam/bam/' -d '{
"bam" : "bam"
}'

curl 'localhost:9200/bam/_search?fields=_source,_timestamp&pretty'
{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "bam",
"_type" : "bam",
"_id" : "DREzT5VFTe2aJQC5ZRQb2g",
"_score" : 1.0, "_source" : {
"bam" : "bam"
}
} ]
}
}

curl -XPOST 'localhost:9200/bambam' -d '{
"mappings" : {
"default" : {
"_timestamp": { "enabled" : true, "store" : true }
}
}
}
}'

curl -XPOST 'localhost:9200/bambam/bambam/' -d '{
"bambam" : "bambam"
}'

curl 'localhost:9200/bambam/_search?fields=_source,_timestamp&pretty'
{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "bambam",
"_type" : "bambam",
"_id" : "bDa7LxPBRQaPnoxj6R96dw",
"_score" : 1.0, "_source" : {
"bambam" : "bambam"
},
"fields" : {
"_timestamp" : 1392089217844
}
} ]
}
}

Is this what you're seeing?

I guess timestamp is being "stored" somewhere in order for facet and query to work. But it is unexpected that without store: true, that no timestamps are returned in result.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0b1dff20-aacd-405c-8db8-ba19295a8f89%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/A476DD88-A61F-40CC-9171-20143905DD9D%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3