Timezone in Simple Query


(Gianni Livolsi) #1

All dates are UTC. Internally, a date maps to a number type long.
When applied on date fields the range filter accepts also a time_zone
parameter
{
"range" : {
"born" : {
"gte": "2012-01-01",
"time_zone": "+1:00"
}
}
}

but this is not possible
{
"match" : {
"post_date" : "2012-01-01",
"time_zone": "+1:00" <<<<<< this do not work }
}

How can i do to permit any users to query correct respect his own timezone...appending
it to query??

Tnx

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/39414b48-f2c5-4faa-b103-96b91c0888b2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2