To run Logstash 5.5.2 need any server like windows server 2008 r2?


(RAMESH KUMAR BAPANAPALLI) #1

Steps:
1.Downloaded latest logstash .zip file and unziped.
2.Created logstash.conf file:
input{stdin{}}
output{stdout{}}
3. In cmd prompt ran cd C:/Logstash5.5.2/bin/
4.C:\logstash-5.5.2\bin>logstash -f logstash.conf
Microsystems was unexpected at this time.

when i follow the same steps in windows server 2008 r2, it was running fine.

can anyone let me know is really we need a server to run logstash.


(SasidharReddy) #2

Do you have proper Java version installed?

May be you can read this further:
https://www.elastic.co/guide/en/logstash/current/installing-logstash.html

check this one as well:


(RAMESH KUMAR BAPANAPALLI) #3

Yes,
C:>java -version
Picked up JAVA_TOOL_OPTIONS: -Djava.vendor="Sun Microsystems Inc."
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

But still i am facing same issue, not able to start logstash.

When i ran echo java home it came output as below:
C:>echo %JAVA_HOME%
C:\PROGRA~1\Java\JDK18~1.0_1


(SasidharReddy) #4

What is the OS version you are trying to run Logstash on? Server OS is not required, it pretty much runs on any computer. I ran on win 7, it worked just fine. However, I use it in Linux environment extensively, so am not the best bet.

Which version of Logstash are you using?
Where do you set -Djava.vendor value? In the environment variable?
Can you remove quotes to "Sun Microsystems, Inc." and try again? Pl check the ref link I gave which has similar issues with ElasticSearch environment. You may get some hint.

I will try when I get some time and get back if I have reproduced and solved the problem.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.