Too many open files


(tetlika) #1

Hi!

we have increased the number of open files in /etc/security/limits...
to 200000 but still getting errors:

Caused by: java.io.FileNotFoundException: (Too many open files)


(Ludovic Levesque) #2

Hi

did you check the current limits with ulimit after setting this value
into /etc/security/limits ?

Ludo

On Wed, Mar 30, 2011 at 9:14 PM, tetlika tetlika@gmail.com wrote:

Hi!

we have increased the number of open files in /etc/security/limits...
to 200000 but still getting errors:

Caused by: java.io.FileNotFoundException: (Too many open files)


(Shay Banon) #3

You can make sure that the setting has been applies to the elasticsearch process by passing -Des.max-open-files=true to the script. Check here: http://www.elasticsearch.org/guide/reference/setup/installation.html.
On Wednesday, March 30, 2011 at 9:47 PM, Ludovic Levesque wrote:

Hi

did you check the current limits with ulimit after setting this value
into /etc/security/limits ?

Ludo

On Wed, Mar 30, 2011 at 9:14 PM, tetlika tetlika@gmail.com wrote:

Hi!

we have increased the number of open files in /etc/security/limits...
to 200000 but still getting errors:

Caused by: java.io.FileNotFoundException: (Too many open files)


(Lee Parker) #4

If you are starting elastic from an init script, setting the file limit in
/etc/security/limits doesn't apply. You will need to put a ulimit -a 200000
line in the init script itself. This will only work if you are running
elastic as root.

Lee

"It doesn't matter whether you are liberal or conservative, but it's
dangerous to always think with exclamation points instead of question
marks."
by Marty Beckerman
On Thu, Mar 31, 2011 at 10:50 AM, Shay Banon
shay.banon@elasticsearch.comwrote:

You can make sure that the setting has been applies to the elasticsearch
process by passing -Des.max-open-files=true to the script. Check here:
http://www.elasticsearch.org/guide/reference/setup/installation.html.

On Wednesday, March 30, 2011 at 9:47 PM, Ludovic Levesque wrote:

Hi

did you check the current limits with ulimit after setting this value
into /etc/security/limits ?

Ludo

On Wed, Mar 30, 2011 at 9:14 PM, tetlika tetlika@gmail.com wrote:

Hi!

we have increased the number of open files in /etc/security/limits...
to 200000 but still getting errors:

Caused by: java.io.FileNotFoundException: (Too many open files)


(system) #5