Topbeat doesn't work in unix machine


(Mahmoud Adel Aldaoor) #1

i've a linux machine that has elasticsearch and kibana installed on it ,and unix machine that has topbeat installed on it , i tried to run the topbeat but with no luck

-bash: ./topbeat: Invalid argument

i tried all below
-./topbeat -e -c topbeat.yml
./topbeat
./topbeat -e -c topbeat.yml -d "publish"
event this command ./topbeat -h :smile:

my machine : 5.10 Generic_150400-17 sun4v sparc sun4v


(Steffen Siering) #2

how did you install topbeat? sparc doesn't seem to be supported by the go compiler.

topbeat uses OS specific methods to collect top-like data. I don't think solaris is in the list (source here: https://github.com/elastic/gosigar)


(Thorsten Nickel) #3

Hi together,

I am kind staying in front of the same problem. Thing is, all the *Beats programms need GO as underlying language. And GO itself is, from what i found out on the internet, not supported for the SPARC architecture on Solaris boxes. It will work on the OpenSolaris flavour, with underlying x86_64 CPU, but, as I said, not for SPARC.
Hence I was not able to get any GO-related programs running on SPARC.

Hope to help,
Thorsten


(Steffen Siering) #4

maybe gccgo (most recent is said to be compatible to go 1.4.2, but beats currently requires 1.5.1) or llgo can be used for cross compiling. But only gccgo seems to support SPARC nowadays.

The go compiler seems to move towards SSA-based intermediate representation (used by llgo translating go compiler SSA to llvm SSA?) + there seems to be some interest on having MIPS supported (https://groups.google.com/forum/#!topic/golang-dev/vNboccLL95c), but no idea about SPARC support.

Still topbeat uses OS specific methods to collect stats, but I can't find any Solaris in here.


(Mahmoud Adel Aldaoor) #5

i just decompress the package
thank you


(system) #6