Transaction name is wrong

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version:
Elasticsearch version:
APM Server version:
APM Agent language and version:

Browser version:

Original install method (e.g. download page, yum, deb, from source, etc.) and version:
Fresh install or upgraded from other version?
Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

transaction name is not what i want, it is "GrailsDispatcherServlet#doGet",
the name is grails framework name, is not my url path
i use "use_path_as_transaction_name=true" and "url_groups=/v1/todo/list*" in file, but is not work.

how can i deal with it

Errors in browser console (if relevant):

Provide logs and/or server output (if relevant):

Hi and welcome to the forum :wave:

Currently, the agent would only use the path as the transaction name if there is no other name set at all. As the agent discovered a Servlet, it names the transaction GrailsDispatcherServlet#doGet so that the use_path_as_transaction_name takes no effect.

I think we should work with different priorities for transaction names. For example, if the name has been set explicitly, it should not be overridden. But if the discovered name is rather unspecific, like the Servlet name, it should be overridden by the use_path_as_transaction_name option.

I have created this issue for that:

Thank you very much.
when Solve the issue I will use it

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.