Transient setting [threadpool.search.queue_size], not dynamically updateable


(Akshaykapoor) #1

I'm trying to change this cluster setting on v5.1.1 but unable to do so because of the following error.

I'm doing the following,

/_cluster/settings

{
  "transient" : {
    "threadpool.search.queue_size" : 1000
  }
}

This results in the following error,

{
"error": {
"root_cause": [
  {
    "type": "remote_transport_exception",
    "reason": "[Du_K45_][X.X.X.X:9300][cluster:admin/settings/update]"
  }
],
"type": "illegal_argument_exception",
"reason": "transient setting [threadpool.search.queue_size], not dynamically updateable"
},
"status": 400
}

I also tried updating threadpool settings with other threadpools but result is still the same.

Is anybody else also facing this issue ? Any help would be great before i open an issue on Github.

Thanks


(Mark Walkom) #2

See https://www.elastic.co/guide/en/elasticsearch/reference/5.1/breaking_50_settings_changes.html#_forbid_changing_of_thread_pool_types


(Akshaykapoor) #3

@warkolm in the document it specifies that the queue_size can be updated and are node_level settings.

Does that mean, these setting cannot be dynamically updated through APIs. For all node-level settings, can it be only done by setting it in the yaml file and would require restart of the node.

If that is the case, then if the node requires a change in the queue_size value, we would have to give it complete restart everytime (don't think this is the best way to do it, i'm probably missing something here). Is there a well defined procedure to achieve this

Elasticsearch 5.1.1 update thread_pool setting


(Mark Walkom) #4

That is correct. Needs to be applied to the config file and then the node needs restarting.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.