Transport SSL must be enabled for setups with production licenses. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]


(Rippfx) #1

Transport SSL must be enabled for setups with production licenses. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]

I upgraded the pre-prod env to 6.2 from 5.6 and the cluster will not start unless I disable the security. I'm having trouble getting the the ssl set up properly. Can someone point me to the right direction?

Thanks


(Lee Drengenberg) #2

You could use self-signed certificates for your pre-prod environment if you can't get real certificates for that environment. Users will get a warning when they open Kibana, but they can go past that. I don't have the documentation link handy but you should find it easy.

Please let me know if you get stuck.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.