Trouble running the ELK-8.3.3 docker-compose instructions. failed to retrieve password hash

Hey folks,

I have copied the tutorial from here and I have been unable to make the basic tutorial work. I have followed it by copying the docker-compose.yaml and .env file, updating my passwords in the .env, and also vp.max_map_count instructions. I'm not sure why it's still not working.

I'm getting some errors in my elasticsearch nodes. docker-compose logs shows me these:

es02_1    | 17:43:56.701 [elasticsearch[es02][generic][T#2]] DEBUG org.elasticsearch.discovery.PeerFinder - address [], node [null], requesting [false] discovery result
es02_1    | org.elasticsearch.transport.ConnectTransportException: [][] connect_exception
es01_1    | 17:44:31.773 [elasticsearch[es01][transport_worker][T#2]] ERROR - failed to retrieve password hash for reserved user [kibana_system]
es01_1    | org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable
es03_1    | 17:43:56.261 [elasticsearch[es03][generic][T#3]] DEBUG org.elasticsearch.discovery.PeerFinder - address [], node [null], requesting [false] discovery result
es03_1    | org.elasticsearch.transport.ConnectTransportException: [][] connect_exception
... stack trace ...
es03_1    | Caused by:$AnnotatedConnectException: Connection refused: es01/
es03_1    | Caused by: Connection refused

My files are identical to the docker-compose.yaml and .env used on the tutorial linked above but I have made a couple changes to start it up and then to try to debug.

  1. I added some passwords as per the tutorial
  2. I changed the ES_PORT in order to follow a previous post with my same error but no luck
  3. I added a and linked it inside the docker-compose.yaml file just to eliminate all the DEBUG and INFO clouding the logs so I could see and post the errors more easily.

Full logs and files are here: Elasticsearch demo errors · GitHub

I've seen this issue report in this forum but not with my underlying cause and I've not gotten anything to work from those threads. For example one similar issue on this forum suggests changing ES_PORT from 9200 to which solved the OP's issue. This did not work for me.

Anyone know what I'm doing wrong here?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.