Trouble with Instructions in 'getting started' documentation

I installed Elasticsearch 7.5.2 from the Windows MSI and tried to follow the instructions in the getting started page at https://www.elastic.co/guide/en/elasticsearch/reference/current/getting-started-install.html
At the point where the instructions ask for two additional instances to be started, i get errors.
elasticsearch -E path.data=data2 -E path.logs=log2
I get the error
org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to bind to [9300]]; nested: BindException[Address already in use: bind];

I followed some discussions and tried to add the following to elasticsearch.yml file
node.max_local_storage_nodes: 4
It did not help.

Note: I used the command
elasticsearch -E path.data=data2 -E path.logs=log2
instead of
elasticsearch.bat -E path.data=data2 -E path.logs=log2
as there is no such batch file in my installation folder.

I might have missed something simple. Help would be appreciated.

This indicates you already have a running Elasticsearch node. You will need to shut that down to proceed.

The 'getting started' tutorial says Start two more instances of Elasticsearch so you can see how a typical multi-node cluster behaves... The additional nodes are assigned unique IDs. Because you’re running all three nodes locally, they automatically join the cluster with the first node.
Is it required to have multiple installations if i have to do this from the same machine?

If you're running on Windows, you may want to use the zip distribution to spin up multiple instances on the same machine.

With the MSI, a single installation of Elasticsearch is installed system-wide on the machine. Whilst it is possible to then start multiple Elasticsearch processes from a single installation, it requires starting from the command line with arguments to override data, log and configuration paths, which is more fiddly than unzipping the zip distribution three times to three separate directories, and starting Elasticsearch in each using the Elasticsearch.bat script. If you need to play only with a single node, the MSI is a reasonable choice.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.