Twitter river proxy settings?

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsegaard@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilato
http://dev.david.pilato.fr/
Twitter : @dadoonet

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

UPDATE: I even tried to set ES_JAVA_OPTS to the same value but it
didn't solve my problem either...:frowning:

Cheers

On Mar 28, 3:44 pm, kodo peter.litsega...@gmail.com wrote:

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

Its not exposed currently, but we can expose the http proxy settings to
configure the twitter river with. I see you opened an issue here:
https://github.com/elasticsearch/elasticsearch-river-twitter/issues/11.

On Wed, Mar 28, 2012 at 3:52 PM, kodo peter.litsegaard@gmail.com wrote:

UPDATE: I even tried to set ES_JAVA_OPTS to the same value but it
didn't solve my problem either...:frowning:

Cheers

On Mar 28, 3:44 pm, kodo peter.litsega...@gmail.com wrote:

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

Are you starting ES via the wrapper? Do you see the env vars when you start ES?

--
Ivan

On Wed, Mar 28, 2012 at 6:52 AM, kodo peter.litsegaard@gmail.com wrote:

UPDATE: I even tried to set ES_JAVA_OPTS to the same value but it
didn't solve my problem either...:frowning:

Cheers

On Mar 28, 3:44 pm, kodo peter.litsega...@gmail.com wrote:

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I believe
I'm experiencing problems with our corporate proxy. I need to be able
to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

I've built v2.3.0 of the twitter river and installed it in v1.3.3 of ES.
I've tried to set the proper proxy settings in JAVA_OPTS and ES_JAVA_OPTS
but the twitter river still fails to start. As we're now writing "year
2014" and this discussion took place more than two years ago I'm wondering
if this proxy issue has been fixed?

Cheers

On Thursday, March 29, 2012 1:52:14 PM UTC+2, kimchy wrote:

Its not exposed currently, but we can expose the http proxy settings to
configure the twitter river with. I see you opened an issue here:
https://github.com/elasticsearch/elasticsearch-river-twitter/issues/11.

On Wed, Mar 28, 2012 at 3:52 PM, kodo <peter.li...@gmail.com <javascript:>

wrote:

UPDATE: I even tried to set ES_JAVA_OPTS to the same value but it
didn't solve my problem either...:frowning:

Cheers

On Mar 28, 3:44 pm, kodo peter.litsega...@gmail.com wrote:

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I
believe

I'm experiencing problems with our corporate proxy. I need to be
able

to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d5cbf506-fecd-470f-b54b-31ea4e6a046e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Peter,

Did you try to set the proxy settings directly in the river configuration,
as stated
in https://github.com/elasticsearch/elasticsearch-river-twitter/issues/11#issuecomment-4811464
?

-- Tanguy

Le mercredi 1 octobre 2014 15:13:35 UTC+2, Peter Litsegård a écrit :

I've built v2.3.0 of the twitter river and installed it in v1.3.3 of ES.
I've tried to set the proper proxy settings in JAVA_OPTS and ES_JAVA_OPTS
but the twitter river still fails to start. As we're now writing "year
2014" and this discussion took place more than two years ago I'm wondering
if this proxy issue has been fixed?

Cheers

On Thursday, March 29, 2012 1:52:14 PM UTC+2, kimchy wrote:

Its not exposed currently, but we can expose the http proxy settings to
configure the twitter river with. I see you opened an issue here:
https://github.com/elasticsearch/elasticsearch-river-twitter/issues/11.

On Wed, Mar 28, 2012 at 3:52 PM, kodo peter.li...@gmail.com wrote:

UPDATE: I even tried to set ES_JAVA_OPTS to the same value but it
didn't solve my problem either...:frowning:

Cheers

On Mar 28, 3:44 pm, kodo peter.litsega...@gmail.com wrote:

Hi David!

Many thanks for your suggestion but unfortunately it didn't solve my
problem:( I set the JAVA_OPTS environment variable to the proxy host/
port and restarted my elastcsearch service but... no:(
It would have been great to just be able to specify, say,
river.twitter.proxy.host=xxxx and river.twitter.proxy.port=yyyy and
maybe username/password in the elasticsearch.yml file.

Cheers

On Mar 28, 2:05 pm, "da...@pilato.fr" da...@pilato.fr wrote:

You could try to modify your jvm settings ?

JAVA_OPTS=-Dhttp.proxyHost=10.90.23.19 -Dhttp.proxyPort=8085
-Dhttp.nonProxyHosts=".mycorp.com|10.|localhost"
-Dhttps.proxyHost=10.90.23.19 -Dhttps.proxyPort=8085
-Dhttps.nonProxyHosts=".mycorp.com|10.|localhost"
HTH

Le 28 mars 2012 à 12:11, kodo peter.litsega...@gmail.com a écrit :

Hi!

I've setup a twitter river in my v0.19 of elasticsearch but I
believe

I'm experiencing problems with our corporate proxy. I need to be
able

to specify the proxy host/port settings. Where/how do I do that?

Cheers

--
David Pilatohttp://dev.david.pilato.fr/
Twitter : @dadoonet

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/30b9a8f4-521a-4379-bc83-729c5f108542%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.