Udp input is crashing


(Tobias Steinhoff) #1

[2018-04-18T10:33:55,772][INFO ][logstash.inputs.udp ] Starting UDP listener {:address=>"0.0.0.0:9988"} [2018-04-18T10:33:55,773][WARN ][logstash.inputs.udp ] UDP listener died {:exception=>#<NameError: uninitialized constant LogStash::Inputs::Udp::IPAddr>, :backtrace=>["org/jruby/RubyModule.java:2746:inconst_missing'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-udp-3.3.1/lib/logstash/inputs/udp.rb:87:in udp_listener'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-udp-3.3.1/lib/logstash/inputs/udp.rb:57:inrun'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:470:in inputworker'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:463:instart_input'"]}`

logstash 5.6.9
os: ubuntu linux 16.04


(Martin Kremers) #2

Same issue here, since going from 5.6.8 to 5.6.9


(Paul Puschmann) #3

But this seems to help:

/usr/share/logstash/bin/logstash-plugin update logstash-input-udp
Updating logstash-input-udp
Updated logstash-input-udp 3.3.1 to 3.3.2

Anyway: this makes me sad.

Logstash 5.6.8-1: logstash-input-udp (3.2.1) (working)

Logstash 5.6.9-1: logstash-input-udp (3.3.1) (broken)

Solution: upgrading logstash-input-udp to 3.3.2

Downgrading is not an option for us since there was a broken logstash-filter-grok in Logstash 5.6.8


(Tobias Steinhoff) #4

thanks, they solved it fast


#5

I had this problem on the docker image I pulled 2 weeks ago.
I didn't specify a version and docker pulled the latest.
It took me many hours to debug until I saw the error using 'docker logs -f logstash' and saw right away the 'UDP listener died' error message. I thought I had a corrupt logstash.conf file, but it looked ok.
Then, I found this thread.
As of 2018/05/08, the 'docker pull logstash' still pulls down 5.6.9. And it still has the problem.

To workaround, I pulled logstash:5.6.8 (docker pull logstash:5.6.8) and run it. It works fine.


(Aj Nouri) #6

Updating udp plugin solved the same issue:

# logstash-plugin update logstash-input-udp
Updating logstash-input-udp
Updated logstash-input-udp 3.3.1 to 3.3.3

(Tj Hsiao) #7

Hi Paul, many thanks for your suggested solution.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.