Ulimit issue in elasticsearch


(sami) #1

moderators : I am pretty sure I created this post but i cant see it in my list of questions so please delete the other one if its visible to you.

I downloaded and untarred the elasticsearch-5.5.1 into a directory, created a user elasticsearch and made it the owner of the directory . i also set the "ulimit -n 65536" in the .bashrc and also placed the line "elasticsearch - nofile 65536" in "/etc/security/limits.conf" .
I can see the "open files" set to 65536 but yet when i start elasticsearch its complaining about the max number of threads low ?

uid=615(elasticsearch) gid=610(elasticsearch) groups=610(elasticsearch),501(hadoop)
[elasticsearch@hadoop1 logs]$
[elasticsearch@hadoop1 logs]$ ulimit -a | grep files
open files (-n) 65536
[elasticsearch@hadoop1 logs]$

[2017-08-02T11:48:05,058][WARN ][o.e.b.BootstrapChecks ] [GYOaxnx] max number of threads [1024] for user [elasticsearch] is too low, increase to at least [2048]


(Julien) #2

Can you try this :
https://www.elastic.co/guide/en/elasticsearch/reference/master/max-number-of-threads.html


(sami) #3

hi Julien
I had already tried ulimit it didn't work , what worked ultimately is setting values for both nproc and nofiles in /etc/security/limits.conf

this issue is fixed for me .
thanks


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.