Unable to access elasticsearch instance from browser after changing the port


(Milad Hamid) #1

Hi,

Just to make my production setup more secure i changed the default http.port in elasticsearch.yml, then i restarted the elasticsearch service. Now i can't access the ES instance from browser!

It was working fine with default port: 9200. Do i need to change other settings?


(David Pilato) #2

Which port do you set?
It can happen that the os refuses it if too low, like 80.


(Milad Hamid) #3

@dadoonet thanks for your quick help. Actually i changed port 9200 to 8900. So is it something that OS may refuse!


(David Pilato) #4

You need to look at elasticsearch logs and share them if you don't understand them.


(andy_zhou) #5

http.port: 19200
node: not use 9300..


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.