Unable to access VM from Host Machine


I am new to elastic search so bear with me for basic questions.

I installed Elastic Search on Ubuntu20.4, everything works on localhost. When I try to access this from my host machine by giving the IP of VM it gives me error of "server isn't responding".

I have so far tried following:
Open up ports on server, disable firewall etc

IPtables show dstports 9200 & 5601 to accept connections from all sources.

tried changing network.hosts to but it crashes the elastic search.

Host Machine: Mac
VM: Ubuntu 20.04
On VM Elastic Search 7.8

Any help please?

Solved it,

It was related to network.hosts parameter in the Elasticsearch.yml file. It should be the same IP as your vm's IP on which your elastic search is running. Secondly setting only this will not work, another parameter discovery.seeds_hosts needs to have the same ip in there as well.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.