Unable to authenticate user [elastic] for rest request

I have launched Elasticsearch(Self-Managed) cluster using Azure marketplace. But not able to access elastic search.
I tried with default user elastic and password which I gave while deploying the cluster.
Getting error "unable to authenticate user [elastic] for REST request"

Here are the steps that I followed,

Selected Existing Virtual Network and Subnet
Selected No for Kibana, logstash and jump box
selected load balance as internal
Selected yes for all data nodes are master eligible
Choose no to configure TLS security

Once deployment is done, I am trying to access internal load balance on 9200 port
But getting error "unable to authenticate user [elastic] for REST request" after I entered the username and password

I tried login through browser, using curl command and also through postman. Getting same error in all cases.
curl -X GET 'http://<loadbalancerip>:9200/_cat/indices?v' -u 'elastic:<elasticpassword>'

I also tried redeploying the cluster with a different password, But still getting same error.

Could you please help me?

Try using a sligthly modified curl request
curl -X GET 'http://elastic:<your-password>@<ip/domain>:9200/_cat/indices?v'

Also please check if the protocol to be used in conjunction with Load balancers in Azure is https or http.

Hi Abhilash_B,

Thanks for your suggestion.

I am getting could not resolve host when I execute

curl -X GET 'http://elastic:<your-password>@<ip/domain>:9200/_cat/indices?v'

FYI, My password has @ symbol.

http and https both can be used. we are using http protocol.

What do your Elasticsearch logs say?

My suspicion is that the password supplied for the elastic built-in superuser has not been successfully applied as part of the deployment process.

Let's continue the discussion for this on the issue opened on the repository: https://github.com/elastic/azure-marketplace/issues/358.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.