Authentication issue while accessing elastic search(It is launched via azure elastic marketplace option)

I have launched an elastic search server using elastic marketplace option over azure.

I am not able to access the elastic search. It is asking me username and password. I have tried with default elastic user and password which I added while creating elastic search.

Here is steps I followed,

  • Loing azure --> click on create --> search for elasticsearch

  • Click on create

  • I filled up Basics, cluster settings,node settings

  • In Kibana & Logstach tab,

  • I selected No in install kibana, logstach and jump box option.

  • I selected load balance as a external

  • In security, I added all required passwords.

  • Choose no to SSL

  • Click on create.

  • Once, deployment is done, I go to external load balance and grab public ip/dns and tried to access elastic search by http://<public_ip>:9200

  • It asked me for credential.

  • I tried with username elastic and password with what I added while creating elastic search.

  • It is not allowing me to go inside elastic.
    Just to check If everything is working, I did SSH in node VM and look on elasticsearcch.yml (I went to etc/elasticsearch). Here is what I found in settings. Just to note, I didn't change anything in configuration. "es" "esdata-1"
      test.logs: /var/log/elasticsearch /datadisks/disk1/elasticsearch/data
      discovery.seed_hosts: ["esmaster-0","esmaster-1","esmaster-2"]
      cluster.initial_master_nodes: ["esmaster-0","esmaster-1","esmaster-2"]
      node.master: false true [site, local]
      node.max_local_storage_nodes: 1
      node.attr.fault_domain: 1
      node.attr.update_domain: 1
      cluster.routing.allocation.awareness.attributes: fault_domain,update_domain
      xpack.license.self_generated.type: trial true
      bootstrap.memory_lock: true

Can anyone please help me?

Thanks a lot in advance!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.