Unable to Configure an index pattern (Kibana 4.5.3)


(Chris) #1

I've got a dev server set up running Elastic 2.3.4 with a single node, Marvel 2.3.4 and Kibana 4.5.3. I'm unable to 'Configure an index pattern' in Kibana settings, and I don't have a green 'create' button.

I've got a couple of indices of my own (autonomy and documents, they have 20 and 14 documents respectively), see my output from http://localhost:9200/_cat/indices;

yellow open .marvel-es-1-2016.08.02 1 1 10054 52  2.9mb  2.9mb 
yellow open autonomy                5 1    20  0 41.7kb 41.7kb_ 
yellow open .kibana                 1 1     2  0 19.1kb 19.1kb 
yellow open .marvel-es-data-1       1 1     2  0  4.1kb  4.1kb 
yellow open documents               5 1    14  0 36.5kb 36.5kb 

When I enter 'documents' into the 'Index name or pattern' field it presents the error;

 Fatal Error 
 Unable to get property 'name' of undefined or null reference 

Version: 4.5.3
Build: 9910

TypeError: Unable to get property 'name' of undefined or null reference
   at Anonymous function (http://localhost:5601/bundles/kibana.bundle.js?v=9910:97273:12)
   at processQueue (http://localhost:5601/bundles/commons.bundle.js?v=9910:42384:12)
   at Anonymous function (http://localhost:5601/bundles/commons.bundle.js?v=9910:42400:28)
   at Scope.prototype.$eval (http://localhost:5601/bundles/commons.bundle.js?v=9910:43628:10)
   at Scope.prototype.$digest (http://localhost:5601/bundles/commons.bundle.js?v=9910:43439:16)
   at Scope.prototype.$apply (http://localhost:5601/bundles/commons.bundle.js?v=9910:43736:14)
   at Anonymous function (http://localhost:5601/bundles/commons.bundle.js?v=9910:51193:18)
   at jQuery.event.dispatch (http://localhost:5601/bundles/commons.bundle.js?v=9910:22747:7)
   at elemData.handle (http://localhost:5601/bundles/commons.bundle.js?v=9910:22433:6)

In Kibana it acknowledges the Marvel index named .marvel-es-1-* in the menu on the left, but wont allow me to specify one of my indices.

I initially thought I might have had installed the Kibana plugin incorrectly (I'm having to use offline methods due to network security). Can anyone point me in the direction to resolve this?


(Lukas Olson) #2

Hmm... did you have the same error before installing Marvel?


(Chris) #3

Lukas, I did not, but I only checked briefly at each stage regarding whether it was installed correctly. I configured Elastic, Kibana and then Marvel before really looking at adding any indices.


(Lukas Olson) #4

Does this happen every time you type "documents" into the "Index name or pattern" field? And does it happen after typing anything at all, or not until you actually type the complete word "documents" into the field?


(Chris) #5

Lukas - it happens every time I type something in, anything in at all, but only once I've finished typing and press return. There's no Create, or Okay button or anything like that either.

EDIT: I was wondering whether Kibana has extracted correctly. I was wondering if there's a way to check.

EDIT #2: I've found this thread which shows what the 'Configure an index pattern' screen looks like for me;

...although in the top left under 'Index patterns' it says;

Warning No default index pattern. You must select or create one to continue.

....but then lists;

.marvel-es-1-*

...under it.


(Chris) #6

RESOLVED: I have no idea why, but it didn't occur to me to type in the index name, and then click anywhere at random on the page outside of the text box, I was looking to click a button. When I click at random, the 'Create' button then suddenly appears.


(Eric) #7

This needs to be bumped-up. I was having the same issue and when I took Chris suggestion it all worked.

This needs to be fixed. I spent a lot of time that I could never get back trying to get Kibana working.


(system) #8