Unable to create an Index Pattern, pattern creation hanging up or failing

ES 6.5.4
Kibana 6.5.4

I've been using the Machine Learning - Data Visualizer feature in Kibana the last few weeks and just recently it started failing when creating an Index Pattern. I go through the steps of importing the data and then the import process crashes when creating the index pattern. I've tried to create an index pattern through the management->index pattern->create index pattern and that just hangs up during the process. I've looked through the logs but nothing stands out. If I should be looking for something in particular I can try and target that.

Hey @Ryan_Downey, if in Chrome you right click and select "Inspect", and then go to the "Console" tab at the top of the screen, do you see any errors output?

That appears to be a permissions issue, which isn't being rendered in a friendly manner. Would you mind running the following two queries using Dev Tools and replying with the response?

GET _xpack/security/_authenticate
GET _xpack/security/user/_privileges

Sent a PM.

Based on those responses which were PM'ed, you have the superuser role, so you should be authorized to do everything.

Would you mind setting the following in your kibana.yml and attaching the logs when this occurs?

logging.verbose: true

kibana.yml updated with:
logging.verbose: true
xpack.security.audit.enabled: true

Fantastic, if you could recreate the issue and then attach your logs, it should give us enough information to being diagnosing.

This issue was being caused because the indices were locked because of low disk space and was evident by running a GET .kibana/_settings and seeing a response similar to the following:

  ".kibana_2" : {
    "settings" : {
      "index" : {
        "number_of_shards" : "1",
        "auto_expand_replicas" : "0-1",
        "blocks" : {
          "read_only_allow_delete" : "true"
        "provided_name" : ".kibana_1",
        "creation_date" : "154192928788386",
        "number_of_replicas" : "1",
        "uuid" : "giheoigheo028r02810",
        "version" : {
          "created" : "6050499"

after freeing up disk space, you can do the following to unlock the .kibana index:

PUT /.kibana/_settings
  "index.blocks.read_only_allow_delete": null

https://www.elastic.co/guide/en/elasticsearch/reference/7.0/disk-allocator.html#disk-allocator has more details

1 Like

Brandon, I seem to be having the same issue where the creating index pattern loading animation just spins.

I am new to Elastic search, but suspect I had a disk space issue. How can I enter the command:

PUT /.kibana/_settings
"index.blocks.read_only_allow_delete": null

Do I use a console of some kind?


Brandon, I am using the readonlyrest plug-in.

Brandon, I figured out how to issue the command.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.