Unable to create dashboards using "ip-x.x.x.x" String


(Suresh Sala) #1

I have field hostname -- > which look's like this "ip-1.2.3.4" When I try to create a dashboard its seperating the hostname into multiple field. I think its because of analyzed field. I have convert it back to not_analyzed.

Example:

curl -XPUT 'http://localhost:9200/vpic/hostname/_mapping' -d '
{
"hostname" : {
"properties" : {
"hostname" : {"type" : "string", "index" : "not_analyzed" }
}
}
}'

But still unble to create virtualize for the same.

ip-X.X.X.X is broken and some weird chart is getting created


(Suresh Sala) #2

@Christian_Dahlqvist Please help.


(Christian Dahlqvist) #3

It looks like the field is indeed analysed. You can not change the mapping for an existing index without reindexing the data. Have you done this?


(Suresh Sala) #4

How to reindex?. I haven't reindexed it but try to change mapping.


(Christian Dahlqvist) #5

You will need to update the index template and then create a new index and write your data there. Look at this post for some options how this can be done.


(system) #6