Unable to fetch mapping with kibana, however there are indices in Elasticsearch


(Meridian) #1

Hello!

I have a problem that I can't configure index pattern.

Error message:
Unable to fetch mapping. Do you have indices matching the pattern?

Seems like that Kibana can't query elasticsearch properly.

curl 'http://localhost:9200/_cat/indices' returns:

yellow open .kibana uciy46GzSGSDs9fUlSnH2g 1 1 1 0 3.1kb 3.1kb
yellow open logstash-2017.09.18 OjAoSQqgQB-GNQIO9xGnKA 5 1 33 0 65.9kb 65.9kb
yellow open logstash-2017.09.19 ed0hHZbcRQK0yyIfbRsAgg 5 1 180059 0 70.8mb 70.8mb

My first thought would be that kibana can't connect to elasticsearch, but that's not true because when elasticsearch is not running I getting a different error that Kibana can't reach it.

OS: RHEL 6

Any help would be appreciated!

Thank you!

Soma


(Mark Walkom) #2

What index pattern are you defining?


(Meridian) #3

Hey!

logstash-* (the default one)

I also forgot to mention that kibana.stderr is empty


(Mark Walkom) #4

That's odd, anything telling in the Kibana logs?


(Meridian) #5

Nothing.

kibana.stderr - empty

kibana.stdout
there are a lot of information about opening the kibana page itself
only interesting is that one:
{"type":"log","@timestamp":"2017-09-18T15:27:45Z","tags":["status","plugin:elasticsearch@5.4.0","info"],"pid":10351,"state":"green","message":"Status changed from yellow to green - Kibana index ready","prevState":"yellow","prevMsg":"Wait
ing for Elasticsearch"}

But it says that everything is ok.


(Meridian) #6

What is also interesing that under dev tools with the next query I see that there are logs in elasticsearch.

GET _search
{
  "query": {
    "match_all": {}
  }
}

Part of the result:
{
"took": 2,
"timed_out": false,
"_shards": {
"total": 11,
"successful": 11,
"failed": 0
},
"hits": {
"total": 180093,
"max_score": 1,
"hits": [
{
"_index": ".kibana",
"_type": "config",
"_id": "5.4.0",
"_score": 1,
"_source": {
"buildNum": 15063
}
},
{
"_index": "logstash-2017.09.18",
"_type": "logs",
"_id": "AV6PgqIYCVprfWztgKrF",
"_score": 1,
"_source": {
"path": "/opt/test/test.2017-09-18.log",
"@timestamp": "2017-09-18T15:01:58.533Z",
"data": "32479234",
"log-level": "DEBUG",
"@version": "1",
"host": "test-elastic-srv",
"thread": "[taskScheduler-2]",
"message": "2017-09-18 00:00:45.527 [taskScheduler-2] DEBUG a.s.d.p.TestServiceImpl - new request",
"logtime": "2017-09-18 00:00:45.527",
"class": "a.s.d.p.TestServiceImpl",
"tags": [
"test-app"
]
}
}
]
}
}


(Meridian) #7

Hello!

I still need help. I tried to reinstall/reconfigure kibana and elasticsearch but it still does not work.

Theres no error in the logs.


#8

Does logstash* work. I am wondering if either the index name or the pattern are using different characters (en-dash vs. hyphen, for example).


(Meridian) #9

Doesn't work. :frowning: I even tried l*


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.