"unable to find usable node.js executable" [SOLVED]


#1

Hello all,

I've successfully installed ES 1.4.2 with Kibana 3.1.2 on a 64-bit Windows 7 Pro machine (for testing reasons I need to install this specific old version).
Entering the directory c:\elasticsearch-1.4.2\bin\kibana and running kibana or kibana.bat from command prompt results in the following error:
unable to find usable node.js executable
ES is running and correctly serving JSON stuff on port 9200.

Thanks in advance for any tip.


(Magnus Bäck) #2

Kibana 3.1.2 doesn't have a bin\kibana or bin\kibana.bat. Which version of Kibana do you actually have?


(Mark Walkom) #3

Also;

Is not right.


#4

It's 3.1.2 as far as I know. I tried downloading the plugin and putting it into the plugin dir as suggested in https://www.elastic.co/guide/en/elasticsearch/reference/1.4/modules-plugins.html, but ES didn't recognize the plugin. Therefore I installed it via the second method, plugin --install elastic/kibana/3.1.2.


#5

Can you please elaborate? The plugin command installed automatically Kibana there.


(Mark Walkom) #6

You could never install KB as a plugin to ES in this manner, so I don't know what's happening.


#7

Ok, I see. Then probably there's an issue -- Elasticsearch shouldn't permit Kibana to be installed as a plugin.

Anyway, I've downloaded again Kibana 3.1.2 and unzipped the archive into c:\kibana-3.1.2. In the guide https://www.elastic.co/guide/en/kibana/3.0/index.html it is not specified how to install Kibana.
When running kibana or kibana.bat, the same error appears: unable to find usable node.js executable.

This happens either with the default configuration, or by specifying explicitly the URL in the config.js file:
elasticsearch: "http://192.168.77.250:9200"

Thanks in advance.

EDIT: Now I see where the misunderstanding might have came from. Wikipedia says (emphasis mine):

"Kibana is an open source data visualization plugin for Elasticsearch. "


(Magnus Bäck) #8

Again, there is no bin/kibana or bin/kibana.bat in Kibana 3.1.2. I have no idea what file you're trying to run.

Kibana 3 is just a web app with no server side parts. The installation consists of configuring an arbitrary web server to serve the Kibana directory from the file system.


#9

I reinstalled Kibana after downloading it from here and it's not in \bin, it's in the main Kibana directory C:\kibana-3.1.2\kibana.bat.
Here's its contents:

@echo off

SETLOCAL

set SCRIPT_DIR=%~dp0
for %%I in ("%SCRIPT_DIR%..") do set DIR=%%~dpfI

set NODE=%DIR%\node\node.exe

WHERE /Q node
IF %ERRORLEVEL% EQU 0 (
  for /f "delims=" %%i in ('WHERE node') do set SYS_NODE=%%i
)

If Not Exist "%NODE%" (
  IF Exist "%SYS_NODE%" (
    set "NODE=%SYS_NODE%"
  ) else (
    Echo unable to find usable node.js executable.
    Exit /B 1
  )
)

TITLE Kibana Server
"%NODE%" %NODE_OPTIONS% "%DIR%\src\cli" %*

:finally

ENDLOCAL

I've done the same install under Linux, with ES and Kibana running on the same machine, and it was straightforward. However, on Windows it is unclear where one should put the unzipped directory, as that's not described in the guide. If you can provide some guidance on this I'd be happy to hear.


(Magnus Bäck) #10

Kibana does not contain a kibana.bat. The file above is kibana.bat from Kibana 4: https://github.com/elastic/kibana/blob/master/bin/kibana.bat

Which Kibana are you trying to run—3 or 4?


#11

I downloaded the Kibana 3.1.2 zipfile again, and you are absolutely right.
The kibana.bat I have in my system must be a remnant of a previous automatic installation of the latest version via the plugin command, which also messed up my Kibana directory. I wiped the old Kibana dir and unzipped the zipfile. I see now that there are also install instructions, so it should be fine.

I need to run a version of Kibana that is compatible with ES 1.4.2. By comparing the past release dates version 3.1.2 - which went out around the same time as ES 1.4.2 - is a good fit.


(Magnus Bäck) #12

That's not a very good reason for running Kibana 3. Kibana 3 won't work with ES 2.0 so unless you want to use unofficial forks of Kibana 3 you won't be able to upgrade ES. I'm sure there are Kibana 4 releases that are compatible with ES 1.4.2.


#13

Thanks, point noted. This is just a test installation and I won't upgrade this ES, but it's good to know.


(Amit Sharma) #14

Hi Magnus,

I am running kibana from terminal and it is showing some ERROR.
Can you please check where is the issue?

It says it is unable to find the node.js. Where do I have to install node.js??

amits@localhost bin]$ ./kibana
which: no node in (/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/amits/.local/bin:/home/amits/bin)
unable to find usable node.js executable.

Thanks in advance.

-amits


(Magnus Bäck) #15

@amits, please start a new thread for your unrelated question.


(system) #16