Unable to get elasticsearch to run with jar hell


#1

I'm totally new to elasticsearch, and I've been asked to look at using Elassandra. I've followed the instructions here: http://doc.elassandra.io/en/v6.2.3.2/installation.html, but it's just not working for me.

I can run bin/cassandra.bat and that works, but when I run bin/cassandra.bat -e to run with Elasticsearch it just seems to die.

I'm running with bin/cassandra.bat -e -p myfile.txt to allow me to use stop-server. I've noticed that when I run without elasticsearch the file is created and lives until I stop the server. Running with elasticsearch it disappears straight away, which is what leads me to say that it has died.

I have checked the logs and found I have a jar hell error. I have NO idea what that means (I am a Windows/DotNet/SQL person, so this is just gibberish to me!). I have googled it and found nothing of any use. I don't know what else I have that is conflicting. I'm not sure if's related, but it still doesn't sound good.

I am running on Windows 10. This is a a standalone dev environment that I want to spin up, do some testing, write some code, and produce a POC at the end of it.

Error is:
java.lang.IllegalStateException: failed to load plugin aggs-matrix-stats due to jar hell
at org.elasticsearch.plugins.PluginsService.checkBundleJarHell(PluginsService.java:475)
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:420)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:146)
at org.elasticsearch.node.Node.(Node.java:307)
at org.elasticsearch.node.Node.(Node.java:246)
at org.apache.cassandra.service.ElassandraDaemon.activate(ElassandraDaemon.java:188)
at org.apache.cassandra.service.ElassandraDaemon.main(ElassandraDaemon.java:554)
Caused by: java.lang.IllegalStateException: jar hell!

I can supply full log files if it helps, but not sure how to upload them here.

Oh, and I appreciate this is Elassandra, not Elasticsearch, but this is the forum I was sent to from the github site.

Hope someone can help me to get this running, thanks :slight_smile:


(David Pilato) #2

Elasticsearch does not support running embedded. It sounds like you are trying to do something like this here.


(Christian Dahlqvist) #3

I have not seen almost any questions related to Elassandra here, so suspect you may have a better chance of getting help through their forum or GitHub repo.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.