Unable to import saved objects in Kibana

Hi all,

I'm looking for some help to import saved objects on Kibana. I have about 75 visualizations and 10 dashboards on my computer and I want to export and import them in Kibana on a server.

But when I drop my .ndjson file on the server in saved objects in have a :
"Sorry, there was an error
The file could not be processed."

Did someone has already faced this issue ?
Thank you in advance

Hi @leo.hamon

I have experienced the same error. I was able to get around it by exporting fewer objects in each export. It is not a explanation of the error, but just a quick fix to get a round it.

1 Like

Thank you for your answer.

Actually, I already have imported the dashboards, but all visualizations (even if I export them one by one) bring me the error I wrote above. I think the issue is the index pattern, I don't know if I must create the same index pattern before import my saved objects, import the index pattern too, or import all visualizations and then create an index pattern.

@leo.hamon when exporting the objects, did you choose to include related objects?


This would have made sure that all related objects are present when loading.


I tried with and without including related objects. Same answer for both..


When you export with related objects, do you see the index patterns in that file?
Could you post a visualization that you can't upload?

You could also test with curl and the export objects API and excludeExportDetails=false, see the documentation - https://www.elastic.co/guide/en/kibana/current/saved-objects-api-export.html. This may give some useful hits

Hi everyone, thank you for helping me. I found where the error came from.. My local Kibana was 7.7.1 and the version on the server was 7.5.2 so there was a conflict.

thank you for your time !

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.