Unable to load excel csv data in elasticsearch, i am new to this requesting a help


(Shaikh Subhan) #1

Hello Mate

I created database config file as below.


input {
stdin {
file {
path => "D:dev tools/data/cars.csv"
start_position => "beginning"
sincedb_path => "/dev/null"

    }

}
Filter {
		csv {
			separator => ","			
			columns => [ "maker",	"model",	"mileage",	"manufacture_year",	"engine_displacement",
						"engine_power",	"body_type",	"color_slug",	"stk_year",	"transmission",	"door_count",
						"seat_count",	"fuel_type", "date_created",	"date_last_seen",	"price_eur", ]
			
		}
		mutate {convert => ["mileage", "integer"] }
		mutate {convert => ["price_eur", "float"] }
		mutate {convert => ["engine_power", "integer"] }
		mutate {convert => ["door_count", "integer"] }
		mutate {convert => ["seat_count", "integer"] }
	}
	
		output {
			elasticsearch {
					hosts => "localhost"
					index => "cars"
					document_type => "sold_cars"
				}
				stdout{ }
				
	}
}

File Name: logstash_cars.config
OS : Windows

using command : bin\logstash -f logstash_cars.config

and getting an error message as below

I am unable to load data ;(
please suggest if there is anything missing in the configuration file.

Thank you so much in advance for your support and concern.

Best Regards
Shaan.....


(Magnus Bäck) #2

path => "D:dev tools/data/cars.csv"

Have you tried reading a file from a location that doesn't have a space in its name?

sincedb_path => “/dev/null”

On Windows, "/dev/null" needs to be "nul".


(Shaikh Subhan) #3

Dear magnusbaeck

Thank you so much for quick reply,

As you said i tried to rename the the folder (without space) and tried to load the file, the issue is same and i tried to edit my config file as "nul" as you adviced still i am not able to load the file. please advice.

Thank you so much in advance for your support.

Best Regards
Shaan…


(Shaikh Subhan) #4

Dear magnusbaeck

i forgot to mention in previous reply. The error msg in cmd has changed after the modification done.

please check below screenshot and advice.

Thank you so much for your support.

Best Regards
Shaan.....


(Magnus Bäck) #5

The error message seems pretty clear to me. Is there a logstash_cars.config in the current directory? If yes, what if you specify the absolute path to the file? It looks like it changes the current directory to the Logstash installation root directory.


(Shaikh Subhan) #6

Dear magnusbaeck

Thank you for quick reply

Now the error msg has changed as below after moving file to correct directory and little correction.

Thank you for your support

Best Regards
Shaan…


(Magnus Bäck) #7

There is no error message. Logstash has started and the stdin input is waiting to receive something.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.