Unable to run Elasticsearch upgrade with docker

Hello there,

after I try to upgrade from 6.8.0 to 7.3.2 . was getting java warrings

$ sudo docker-compose up
Starting elasticsearch ... done
Attaching to elasticsearch
elasticsearch | OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
elasticsearch exited with code 1

even I try to role back it wont work still get the same error.

below is my docker -compose file

- bash

- -c

- "bin/elasticsearch-plugin install -b repository-s3;

bin/elasticsearch-keystore create;

echo AKIA3TEYUDEZ4SZW7G4B | bin/elasticsearch-keystore add --stdin -f s3.client.default.access_key;

echo DxnJu/KpW44DAxNRLrqu0MeZi310nPfV/Pi8NOtK | bin/elasticsearch-keystore add --stdin -f s3.client.default.secret_key;

/usr/local/bin/docker-entrypoint.sh elasticsearch"

  - cluster.name=dev-ops-elasticsearch-cluster-extra
  - bootstrap.memory_lock=true
  - bootstrap.system_call_filter=false
  - "ES_JAVA_OPTS=-Xms7178m -Xmx7178m -Djava.io.tmpdir=/tmp/elasticsearch"
  - /data/log/elasticsearch:/var/log/elasticsearch
  - /data/tmp/elasticsearch:/tmp/elasticsearch
  - /opt/elasticsearch/config/elasticsearch.yml:/usr/share/elasticsearch/config/elasticsearch.yml
  - /opt/elasticsearch/config/log4j2.properties:/usr/share/elasticsearch/config/log4j2.properties
  - /opt/elasticsearch/config/synonym.txt:/usr/share/elasticsearch/config/analysis/synonym.txt
  - /opt/elasticsearch/config/stopword.txt:/usr/share/elasticsearch/config/analysis/stopword.txt
  - /data/var/lib/elasticsearch:/usr/share/elasticsearch/data1
  - /data/tmp/backup:/tmp/backup

  - 9200:9200
  - 9300:9300
network_mode: host

please help

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.