Unable to run Kibana-7.2 on ScientificLinux-6


I have been running kibana on an SL-6 system (derivative of Redhat-6). Kibana till 7.1.1 ran perfectly fine but on installing 7.2.0, I get an error

FATAL Error: /lib64/libc.so.6: version 'GLIBC_2.14' not found (required by /usr/share/kibana/node_modules/@elastic/nodegit/build/Release/nodegit.node)

I think this is because kibana-7.2 bundles new version of node.js that requires glibc>2.12 (one bundled with Redhat6). I tried to manually install glibc-2.14 and glibc-2.17 in a custom location. The install worked correctly but I can't tell node to pick those libraries

# LD_LIBRARY_PATH=/opt/glibc-2.14/lib/ /usr/share/kibana/node/bin/node --no-warnings --max-http-header-size=65536 "/usr/share/kibana/src/cli" --allow-root

  log   [11:50:20.627] [fatal][root] Error: /usr/share/kibana/node_modules/@elastic/nodegit/build/Release/nodegit.node: cannot enable executable stack as shared object requires: Operation not permitted

Clearing the executable stack bit

# execstack -c /usr/share/kibana/node_modules/\@elastic/nodegit/build/Release/nodegit.node

and re-running gives a segmentation fault

Using 2.17, gives a different error

# LD_LIBRARY_PATH=/opt/glibc-2.17/lib/ /usr/share/kibana/node/bin/node --no-warnings --max-http-header-size=65536 "/usr/share/kibana/src/cli" --allow-root
/usr/share/kibana/node/bin/node: error while loading shared libraries: __vdso_time: invalid mode for dlopen(): Invalid argument

Is Redhat-6 no longer officially supported? Or does anyone have pointers on how to get this to work?


There was an issue in the nodegit dependency that stops it from loading in 7.2.0. There is a fix out for 7.2.1 which should be coming out soon (a week or so).

Is there any workaround to get rid of this problem before releasing 7.2.1?
A thing like this for another bug in 7.2.0

Yep, the one that you linked would be the workaround.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.