Unable to start Elasticsearch 7.0 on Windows 10


(Gabriele D'antona) #1

Hello,
when starting Elasticsearch on my machine, I get this error. Already tried to disable the antivirus, but with no luck:

C:\Program Files\Elastic\Elasticsearch\7.0.0\bin>elasticsearch.exe
[2019-04-15T10:23:24,555][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [SPXMIW3825] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: org.elasticsearch.bootstrap.BootstrapException: java.io.IOException: Cannot run program "\?\C:\PROGRA~1\Elastic\ELASTI~1\70FE6E~1.0\modules\X-PACK~2\platform\WINDOW~1\bin\CONTRO~1.EXE": CreateProcess error=5, Accesso negato
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.0.0.jar:7.0.0]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.0.0.jar:7.0.0]
Caused by: org.elasticsearch.bootstrap.BootstrapException: java.io.IOException: Cannot run program "\?\C:\PROGRA~1\Elastic\ELASTI~1\70FE6E~1.0\modules\X-PACK~2\platform\WINDOW~1\bin\CONTRO~1.EXE": CreateProcess error=5, Accesso negato
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:166) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.0.0.jar:7.0.0]
... 6 more
Caused by: java.io.IOException: Cannot run program "\?\C:\PROGRA~1\Elastic\ELASTI~1\70FE6E~1.0\modules\X-PACK~2\platform\WINDOW~1\bin\CONTRO~1.EXE": CreateProcess error=5, Accesso negato
at java.lang.ProcessBuilder.start(Unknown Source) ~[?:1.8.0_201]
at org.elasticsearch.bootstrap.Spawner.spawnNativeController(Spawner.java:118) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:86) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:164) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.0.0.jar:7.0.0]

    at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.0.0.jar:7.0.0]
    ... 6 more

Caused by: java.io.IOException: CreateProcess error=5, Accesso negato
at java.lang.ProcessImpl.create(Native Method) ~[?:1.8.0_201]
at java.lang.ProcessImpl.(Unknown Source) ~[?:1.8.0_201]
at java.lang.ProcessImpl.start(Unknown Source) ~[?:1.8.0_201]
at java.lang.ProcessBuilder.start(Unknown Source) ~[?:1.8.0_201]
at org.elasticsearch.bootstrap.Spawner.spawnNativeController(Spawner.java:118) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Spawner.spawnNativeControllers(Spawner.java:86) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:164) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.0.0.jar:7.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.0.0.jar:7.0.0]
... 6 more


(Mohan Kumar U) #2

is it not bat file that you should run?


(Gabriele D'antona) #3

Hello,
I've installed the .msi, so there is no ".bat" file to run. But, if I download instead the standalone .zip, there is the .bat file but the error is the same.
Thanks