Unable to write kibana uuid file

I am trying to install ELK stack on Centos7 server using this: https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-elastic-stack.html I had older version of ELK on the same server which I have removed already.

I installed elasticsearch. While installing Kibana I am facing the below error:

.

Please assist

Hi @ishan.abhinit,

Welcome to our community! Can you provide a bit more details? What is in your kibana.yml, please post hiding any sensitive data? Also how are you installing ELK and which version?

Thanks,
Liza

Yes, I am installing ELK 7.6.2 on CentOS7 from here:
https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-elastic-stack.html

Contentsof kibana.yml file:

# Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
#elasticsearch.hosts: ["http://localhost:9200"]

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: "kibana"
#elasticsearch.password: "pass"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"

Thanks @ishan.abhinit, it looks like you downloaded the tar file and are running it as ./bin/kibana.

Is it possible you unzipped and untared the Kibana packaged as root or a different user than the user you are running as, this would cause the permission issue you are seeing. Please check and let us know.

I just used sudo to untar the package.
Then I executed the command using sudo and looks like it is working. But now I am getting a new error and a warning.

I read a bit about x-pack and looks like x-pack is installed by default on elasticsearch 7.6.2 and kibana 7.6.2. So I am not sure what this warning is about?

Hi @ishan.abhinit,

If you are using default it should come up with basic license, have you made any updates to the elasticsearch.yml or kibana.yml? Please ensure that both packages are for 7.6.2.

Thanks,
Liza

No, I haven't made any changes to both the yml files. I previously had version 2.4.6 of ELK installed on this machine. Looks like that is what is interfering with the settings. Before downloading the latest version (7.6.2) I had removed the older one but still the problem persists.
Also the below command shows me the older version--> curl http://127.0.0.1:9200

image

Hi @ishan.abhinit,

It looks like your old installation is still running on port 9200, can you search for and terminate the process associated with that? Also, elasticsearch will bind to another port if the default 9200 is in use, so if you started your newer installation you can get the port from the elasticsearch log. Hope this helps.

Thanks,
Liza

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.