Unresolved or ambiguous specs during Gem::Specification.reset: date (>= 0), but cannot run gem command to resolve

Running the logstash-plugin list or logstash-plugin install commands cause the following error. How can I troubleshoot and resolve this problem with the gem command that is built into Logstash?

WARN: Unresolved or ambiguous specs during Gem::Specification.reset:
      date (>= 0)
      Available/installed versions of this gem:
      - 3.3.4
      - 3.3.3
WARN: Clearing out unresolved specs. Try 'gem cleanup <gem>'
Please report a bug if this causes problems.

The gem command is not installed at the OS-level, but does appear to exist within Logstash's own directory structure, however running that gem executable causes the following error.

[root@server-hostname ~]# find /usr/share/logstash/* -name "gem" -print
/usr/share/logstash/vendor/jruby/bin/gem
[root@server-hostname ~]# cd /usr/share/logstash/vendor/jruby/bin/
[root@server-hostname bin]# ./gem list
/usr/bin/env: jruby: No such file or directory
[root@server-hostname bin]#

Logstash v8.12.0-1 installed via the official Elastic rpm repo. OS is Amazon Linux.

Was this ever resolved?

Unfortunately, no. We still get the same error, even after updating our logstash package.

As an aside, we also have reason to believe that this error is related to an issue we are experiencing where the logstash-filter-tld plugin cannot be properly installed. The install appears to complete, but the plugin is not listed anywhere within the output of bin/logstash-plugin update (the plugin was either updated or not).

If anyone has any insight, we'd appreciate if you could share.