Update Mapping for JDBC river freezes till next request is received


(André Morais) #1

Hello,

I am using the JDBC river plugin (latest version with the name "
elasticsearch-river-jdbc-2.2.1.jar" on ES 0.90.5) and recently found that
sometimes a new river takes a long time to start. I am creating the river
and waiting for full river population by periodically counting indexed
documents till full count is reached. I then create an alias. Other rivers
are created subsequently.

Do you know of any reason for this strange behaviour?

Thanks for your help!

        André Morais

Here are the messages that show this behaviour: I create the river, the
alias creation times out, one hour passes; I then create another river, the
first one starts to index documents, and then the second one.

[2014-05-26 21:08:51,464][INFO ][cluster.metadata ] [Outrage]
[_river] update_mapping [clfb_meosudoeste20140526210851_river] (dynamic)
[2014-05-26 21:13:57,350][DEBUG][action.admin.indices.alias] [Outrage]
failed to perform aliases
org.elasticsearch.indices.IndexMissingException:
[clfb_meosudoeste20140526210851] missing
at
org.elasticsearch.cluster.metadata.MetaDataIndexAliasesService$1.execute(MetaDataIndexAliasesService.java:96)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:722)
[2014-05-26 22:03:25,146][DEBUG][action.index ] [Outrage]
Sending mapping updated to master: index [_river] type
[clfb_salsa20140526220325_river]
[2014-05-26 22:03:25,146][INFO ][cluster.metadata ] [Outrage]
[_river] update_mapping [clfb_salsa20140526220325_river] (dynamic)
[2014-05-26 22:03:25,146][INFO ][river.jdbc ] [Outrage]
[jdbc][clfb_meosudoeste20140526210851_river] starting JDBC river: URL
[jdbc:mysql://localhost:3306/clfb_meosudoeste], driver
[com.mysql.jdbc.Driver], strategy [oneshot], index
[clfb_meosudoeste20140526210851]/[jdbc]
[2014-05-26 22:03:30,184][INFO ][cluster.metadata ] [Outrage]
[clfb_meosudoeste20140526210851] creating index, cause [api], shards
[5]/[1], mappings []
[2014-05-26 22:03:30,200][INFO ][river.jdbc ] [Scarlet
Spider] [jdbc][clfb_salsa20140526220325_river] starting JDBC river: URL
[jdbc:mysql://localhost:3306/clfb_salsa], driver [com.mysql.jdbc.Driver],
strategy [oneshot], index [clfb_salsa20140526220325]/[jdbc]

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/757a069a-a5c1-4849-8ae5-c21a44d5be92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

You should upgrade ES, there were bugs fixed regarding cluster update
service and rivers.

Jörg

On Tue, May 27, 2014 at 6:44 PM, André Morais anoeee@gmail.com wrote:

Hello,

I am using the JDBC river plugin (latest version with the name "
elasticsearch-river-jdbc-2.2.1.jar" on ES 0.90.5) and recently found that
sometimes a new river takes a long time to start. I am creating the river
and waiting for full river population by periodically counting indexed
documents till full count is reached. I then create an alias. Other rivers
are created subsequently.

Do you know of any reason for this strange behaviour?

Thanks for your help!

        André Morais

Here are the messages that show this behaviour: I create the river, the
alias creation times out, one hour passes; I then create another river, the
first one starts to index documents, and then the second one.

[2014-05-26 21:08:51,464][INFO ][cluster.metadata ] [Outrage]
[_river] update_mapping [clfb_meosudoeste20140526210851_river] (dynamic)
[2014-05-26 21:13:57,350][DEBUG][action.admin.indices.alias] [Outrage]
failed to perform aliases
org.elasticsearch.indices.IndexMissingException:
[clfb_meosudoeste20140526210851] missing
at
org.elasticsearch.cluster.metadata.MetaDataIndexAliasesService$1.execute(MetaDataIndexAliasesService.java:96)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:722)
[2014-05-26 22:03:25,146][DEBUG][action.index ] [Outrage]
Sending mapping updated to master: index [_river] type
[clfb_salsa20140526220325_river]
[2014-05-26 22:03:25,146][INFO ][cluster.metadata ] [Outrage]
[_river] update_mapping [clfb_salsa20140526220325_river] (dynamic)
[2014-05-26 22:03:25,146][INFO ][river.jdbc ] [Outrage]
[jdbc][clfb_meosudoeste20140526210851_river] starting JDBC river: URL
[jdbc:mysql://localhost:3306/clfb_meosudoeste], driver
[com.mysql.jdbc.Driver], strategy [oneshot], index
[clfb_meosudoeste20140526210851]/[jdbc]
[2014-05-26 22:03:30,184][INFO ][cluster.metadata ] [Outrage]
[clfb_meosudoeste20140526210851] creating index, cause [api], shards
[5]/[1], mappings []
[2014-05-26 22:03:30,200][INFO ][river.jdbc ] [Scarlet
Spider] [jdbc][clfb_salsa20140526220325_river] starting JDBC river: URL
[jdbc:mysql://localhost:3306/clfb_salsa], driver [com.mysql.jdbc.Driver],
strategy [oneshot], index [clfb_salsa20140526220325]/[jdbc]

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/757a069a-a5c1-4849-8ae5-c21a44d5be92%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/757a069a-a5c1-4849-8ae5-c21a44d5be92%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHpGOG1PoLqTGyJ%3D6EjFUa4kwTDpdmkxtBf9W0Ov8vnVg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3