Updated 5.6,X to 6.2 and all my data is gone


(Dor Juravski) #1

Hello, I just used yum update to upgrade my elk stack from 5.6.2 to 6.2.
Once done - logging into it shows nothing, no existing indexes, visualizations, data. All gone.

The elasticsearch.yml file still points to the default and original location /var/lib/elasticsearch

I still see old indices files in there.

Any suggestions?


(David Pilato) #2

Did you use the migration helper in X-Pack basic to check if everything was compatible and ready to upgrade?
What are the logs saying?


(Dor Juravski) #3

x-pack was not installed to begin with. The upgrade was just done to the libraries.
A similar upgrade (5.6.X to 6.X) worked for me in the past with no harm to the data.

I'll look at the logs but was wondering if this is something people experienced.


(Dor Juravski) #4

Perhaps this gives more insight: the last sentence in these logs is the only indicator of a problem, from what I could understand:
recovered [0] indices into cluster_state (see below elasticsearch.log quoted)

elasticsearch_deprecation.log

[2018-01-08T08:49:37,396][WARN ][o.e.d.r.RestController   ] Content type detection for rest requests is deprecated. Specify the content type using the [Content-Type] header.
[2018-02-07T11:03:08,975][WARN ][o.e.d.i.m.MapperService  ] Setting index.mapper.dynamic is deprecated since indices may not have more than one type anymore.
[2018-02-07T11:03:09,044][WARN ][o.e.d.i.m.MapperService  ] [_default_] mapping is deprecated since it is not useful anymore now that indexes cannot have more than one type
[2018-02-07T11:03:16,607][WARN ][o.e.d.i.m.MapperService  ] Setting index.mapper.dynamic is deprecated since indices may not have more than one type anymore.
[2018-02-07T11:03:16,619][WARN ][o.e.d.i.m.MapperService  ] [_default_] mapping is deprecated since it is not useful anymore now that indexes cannot have more than one type
[2018-02-07T11:13:15,653][WARN ][o.e.d.a.a.i.t.p.PutIndexTemplateRequest] Deprecated field [template] used, replaced by [index_patterns]
[2018-02-07T11:13:15,675][WARN ][o.e.d.i.m.MapperService  ] [_default_] mapping is deprecated since it is not useful anymore now that indexes cannot have more than one type
[2018-02-07T11:16:25,651][WARN ][o.e.d.c.ParseField       ] Deprecated field [all_fields] used, replaced by [Set [fields] to `*` instead]
[2018-02-07T11:16:25,686][WARN ][o.e.d.c.ParseField       ] Deprecated field [inline] used, expected [source] instead
[2018-02-07T11:16:25,708][WARN ][o.e.d.c.ParseField       ] Deprecated field [all_fields] used, replaced by [Set [fields] to `*` instead]
[2018-02-07T11:16:25,713][WARN ][o.e.d.c.ParseField       ] Deprecated field [inline] used, expected [source] instead

elasticsearch.log

[2018-02-07T11:02:56,591][INFO ][o.e.n.Node               ] [] initializing ...
[2018-02-07T11:02:56,657][INFO ][o.e.e.NodeEnvironment    ] [Gb4V_yx] using [1] data paths, mounts [[/var (/dev/mapper/datavg-var)]], net usable_space [321.8gb], net total_space [442.7gb], types [ext3]
[2018-02-07T11:02:56,657][INFO ][o.e.e.NodeEnvironment    ] [Gb4V_yx] heap size [7.9gb], compressed ordinary object pointers [true]
[2018-02-07T11:02:56,658][INFO ][o.e.n.Node               ] node name [Gb4V_yx] derived from node ID [Gb4V_yxtTWqI9kMkBuf2hg]; set [node.name] to override
[2018-02-07T11:02:56,658][INFO ][o.e.n.Node               ] version[6.2.0], pid[122171], build[37cdac1/2018-02-01T17:31:12.527918Z], OS[Linux/3.10.0-693.2.2.el7.x86_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_45/25.45-b02]
[2018-02-07T11:02:56,659][INFO ][o.e.n.Node               ] JVM arguments [-Xms2g, -Xmx8g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch]
[2018-02-07T11:02:57,283][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [aggs-matrix-stats]
[2018-02-07T11:02:57,283][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [analysis-common]
[2018-02-07T11:02:57,283][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [ingest-common]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [lang-expression]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [lang-mustache]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [lang-painless]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [mapper-extras]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [parent-join]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [percolator]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [rank-eval]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [reindex]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [repository-url]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [transport-netty4]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] loaded module [tribe]
[2018-02-07T11:02:57,284][INFO ][o.e.p.PluginsService     ] [Gb4V_yx] no plugins loaded
[2018-02-07T11:02:59,561][INFO ][o.e.d.DiscoveryModule    ] [Gb4V_yx] using discovery type [zen]
[2018-02-07T11:03:00,081][INFO ][o.e.n.Node               ] initialized
[2018-02-07T11:03:00,081][INFO ][o.e.n.Node               ] [Gb4V_yx] starting ...
[2018-02-07T11:03:00,276][INFO ][o.e.t.TransportService   ] [Gb4V_yx] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2018-02-07T11:03:00,287][WARN ][o.e.b.BootstrapChecks    ] [Gb4V_yx] initial heap size [2147483648] not equal to maximum heap size [8589934592]; this can cause resize pauses and prevents mlockall from locking the entire heap
[2018-02-07T11:03:03,339][INFO ][o.e.c.s.MasterService    ] [Gb4V_yx] zen-disco-elected-as-master ([0] nodes joined), reason: new_master {Gb4V_yx}{Gb4V_yxtTWqI9kMkBuf2hg}{Q5RTUcGSS4yFFTZXIpGRsg}{127.0.0.1}{127.0.0.1:9300}
[2018-02-07T11:03:03,344][INFO ][o.e.c.s.ClusterApplierService] [Gb4V_yx] new_master {Gb4V_yx}{Gb4V_yxtTWqI9kMkBuf2hg}{Q5RTUcGSS4yFFTZXIpGRsg}{127.0.0.1}{127.0.0.1:9300}, reason: apply cluster state (from master [master {Gb4V_yx}{Gb4V_yxtTWqI9kMkBuf2hg}{Q5RTUcGSS4yFFTZXIpGRsg}{127.0.0.1}{127.0.0.1:9300} committed version [1] source [zen-disco-elected-as-master ([0] nodes joined)]])
[2018-02-07T11:03:03,365][INFO ][o.e.h.n.Netty4HttpServerTransport] [Gb4V_yx] publish_address {127.0.0.1:9200}, bound_addresses {[::1]:9200}, {127.0.0.1:9200}
[2018-02-07T11:03:03,365][INFO ][o.e.n.Node               ] [Gb4V_yx] started
[2018-02-07T11:03:03,379][INFO ][o.e.g.GatewayService     ] [Gb4V_yx] recovered [0] indices into cluster_state

(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.