Updating mapping dynamic false -> dynamic strict unexpected behaviour

Hi List,

I'm trying to update a mapping for one of my types using the put mapping
API [1]

Precisely I'd like to set for some objects the "dynamic" property changing
it from false to strict

I'm executing the following

curl -X PUT 'http://localhost:9200/my_index'

curl -X PUT -d
'{"my_type":{"dynamic":"false","properties":{"fields":{"type":"string"}}}}'
'http://localhost:9200/my_index/my_type/_mapping'

curl -X PUT -d
'{"my_type":{"dynamic":"strict","properties":{"fields":{"type":"string"}}}}'
'http://localhost:9200/my_index/my_type/_mapping'

but at the end when I check the resulting mapping

curl 'http://localhost:9200/my_index/my_type/_mapping'

{"my_type":{"dynamic":"false","properties":{"fields":{"type":"string"}}}

I would expect to see the dynamic attribute changed to strict, what am I
doing wrong?

[1] http://www.elasticsearch.org/guide/reference/api/admin-indices-put-mapping/

Thanks in advance for your help

Paolo

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

is it possible, that you are hitting this issue


Setting the dynamic setting during runtime will be possible in the next
version.

--Alex

On Thu, Jul 25, 2013 at 1:50 PM, Paolo Negri hungryblank@gmail.com wrote:

Hi List,

I'm trying to update a mapping for one of my types using the put mapping
API [1]

Precisely I'd like to set for some objects the "dynamic" property changing
it from false to strict

I'm executing the following

curl -X PUT 'http://localhost:9200/my_index'

curl -X PUT -d
'{"my_type":{"dynamic":"false","properties":{"fields":{"type":"string"}}}}'
'http://localhost:9200/my_index/my_type/_mapping'

curl -X PUT -d
'{"my_type":{"dynamic":"strict","properties":{"fields":{"type":"string"}}}}'
'http://localhost:9200/my_index/my_type/_mapping'

but at the end when I check the resulting mapping

curl 'http://localhost:9200/my_index/my_type/_mapping'

{"my_type":{"dynamic":"false","properties":{"fields":{"type":"string"}}}

I would expect to see the dynamic attribute changed to strict, what am I
doing wrong?

[1]
http://www.elasticsearch.org/guide/reference/api/admin-indices-put-mapping/

Thanks in advance for your help

Paolo

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.