Updating preinstalled Logstash gems


I have already developed multiple logstash-filter plugins for my company, which are located in our private repository. I don't have any problems installing them and using them in our Logstash.

I had to make changes to the webhdfs and logstash-output-webhdfs plugin and uploaded them into our repository. The problem I am currently facing is that those two plugins come already preinstalled with Logstash and I am unable to properly update those plugins with my changes.

What I tried:

Removed the logstash-output-webhdfs line and inserted the following line into the Gemfile:

source "http://our.own.gem.repo.com/the/path/to/it" do
  gem 'logstash-output-webhdfs'

Update plugin + output:

./bin/logstash-plugin update logstash-output-webhdfs
Updating logstash-output-webhdfs
No plugin updated

I also tried removing the plugin and reinstalling the plugin, but it doesn't install the plugin from our private repository.


One interesting discovery that I made is that, after I run any of those commands, the Gemfile changes to that:

source "https://rubygems.org"
source "https://repository.porscheinformatik.com/repository/rubygems-inhouse/"
gem "logstash-output-webhdfs"

Either he now tries to download the logstash-output-webhdfs plugin from the official website (which I don't believe, reason being, I tried the steps without the 'source "https://rubygems.org" line and same outcome ') or has a local backup from the plugin which it uses when updating.

Can anyone help me pls?

I am using https://www.elastic.co/guide/en/logstash/6.8/installing-logstash.html for installing Logstash via yum.



Can anyone help?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.