Upgrade elasticsearch 1.7.1 to 2.2


#1

I upgraded our QA environment running centos 6.5 Elasticsearch 1.7.1 to 2.2
I used the yum repository:

yum -y install elasticsearch

When I tried to start Elasticsearch

service elasticsearch start

I get the following error:
java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [marvel]. Was the plugin built before 2.0?
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:380)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:128)
at org.elasticsearch.node.Node.(Node.java:146)
at org.elasticsearch.node.Node.(Node.java:128)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
Caused by: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/plugins/marvel/plugin-descriptor.properties

Then I tried to install marvel 2.0 and I got another error:
cd /usr/share/elasticsearch
sudo bin/plugin install license

CONF_FILE setting is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.


(Mike Simos) #2

Hi,

Check /etc/sysconfig/elasticsearch (rpm) or /etc/default/elasticsearch (debian) for CONF_FILE. And comment this out and make sure elasticsearch.yml is in the same directory as CONF_DIR, presumably /etc/elasticsearch.


#3

Thank you, that fixed the problem


(system) #4