Where are the License and Marvel downloadable plugins for ES 2.2.1?

monitoring

(Dhawal Parkar) #1

A while back on the Marvel offline installation links there were links for version 2.2.1, but they didn't work.

Example : https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/2.2.1/license-2.2.1

I tried using 2.2.0 with ES 2.2.1 but I am getting the following error:

[2016-03-17 02:09:30,185][ERROR][bootstrap ] Exception
java.lang.IllegalArgumentException: Plugin [license] is incompatible with Elasticsearch [2.2.1]. Was designed for version [2.2.0]
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:118)
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:378)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:128)
at org.elasticsearch.node.Node.(Node.java:146)
at org.elasticsearch.node.Node.(Node.java:128)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

Please point out the links and update the offline installation pages for Marvel.


(Dhawal Parkar) #2

@tsullivan


(Dhawal Parkar) #3

Here is the link : https://www.elastic.co/guide/en/marvel/current/installing-marvel.html#offline-installation


(Steve Kearns) #4

Hi Dhawal,

We're updating that page with the links for 2.2.1.

In the mean time, you can just bump the version number in the URL:

https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/2.2.1/license-2.2.1.zip
https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/marvel-agent/2.2.1/marvel-agent-2.2.1.zip
https://download.elasticsearch.org/elasticsearch/marvel/marvel-2.2.1.tar.gz

Thanks,
Steve


(Dhawal Parkar) #6

The 2nd link for marvel agent is not working.


(Dhawal Parkar) #8

NVM ... there is a typo in that link ... here is the correct one :

https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/marvel-agent/2.2.1/marvel-agent-2.2.1.zip

Thanks @skearns !


(Steve Kearns) #9

Whoops, good catch! I updated the link in my earlier post :slight_smile:

Glad you're back up and running!


(Dhawal Parkar) #10

@skearns ... I tried to install these plugins but I am seeing errors ... here is the issue : License 2.1.1 Jar Hell Error

Is the license plugin suppose to have plugin-security.policy file ? Its not there in the zip. There is one in Marvel-Agent though. But I haven't been able to test Marvel-Agent yet since plugin is not yet installed.


(system) #11