Unable to dowload marvel-2.4.2 for offline installation

monitoring

#1

Hi,

There is no available link to download marvel-2.4.2.

Link https://download.elasticsearch.org/elasticsearch/marvel/marvel-2.4.2.tar.gz doesn't work.

Could you please also update this page https://www.elastic.co/guide/en/marvel/current/installing-marvel.html#package-installation. There is a wrong mixed version between license-2.4.2.zip, marvel-agent-2.4.2.zip and marvel-2.4.1.tar.gz

Thanks


(Court Ewing) #2

The docs are actually not incorrect: For the time being, the correct version of the Kibana plugins to install is 2.4.1.


#3

Hi,

You're probably right but the documentation is not clear.

On this page https://www.elastic.co/guide/en/marvel/current/installing-marvel.html#package-installation,
You can read :

Marvel 2.4.2 requires:
Java 7 or later
Elasticsearch 2.4.2
Kibana 4.6.1
Elasticsearch License 2.4.2 plugin

But marvel 2.4.2 doesn't exist, the last version of marvel plugin available is the 2.4.1

So if i only update marvel-agent and license plugins in 2.4.2 , the versions will be inconsistent with the marvel plugin in 2.4.1

Am i wrong?


(Court Ewing) #4

The latest version of the marvel plugin for Elasticsearch is 2.4.2, whereas the latest version of the marvel plugin for Kibana is 2.4.1, and both of those versions are compatible with each other. We could definitely stand to make this more clear in the documentation, though!


#5

Thanks for your help.

I was just a little bit confused


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.