Unable to install Marvel plugin. Tried online, offline both

monitoring

(Prakhar Singh) #1

I'm very new to elasticsearch. I am following the introduction walkthrough video religiously, but I am unable to download marvel.
Procedure:

  1. Made suggested changes to config/elasticsearch.yml
  2. Ran ./bin/plugin install license - Successful
  3. Ran ./bin/plugin install marvel-agent - Successful
  4. Ran ./bin/plugin install elasticsearch/marvel/latest
    Error : failed to download out of all possible locations
  5. Alternately downloaded zip and tried offline install
    Ran ./bin/plugin install file:///home/path/to/marvel-2.1.0.tar.gz
    Report:
    Verifying file:/home/path/to/marvel-2.1.0.tar.gz checksums if available ...
    NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
    ERROR: Could not find plugin descriptor 'plugin-descriptor.properties' in plugin zip

What am I doing wrong?


(Tanguy) #2

Hi,

It looks like you're installing marvel multiple times, only steps 1 & 2 are required to install marvel in an elasticsearch node.

This page may help you: https://www.elastic.co/guide/en/marvel/current/getting-started.html

-- Tanguy


(Prakhar Singh) #3

Hey @tanguy ,

Thanks for the reply. But in that case I should be able to see something at : http://localhost:9200/_plugin/marvel/
which I'm not able to. Any reasons, why?


(Tanguy) #4

Are you using elasticsearch 2.x? If so, then the link I gave you explains how to install everything including Kibana and the marvel plugin to see marvel's dashboards.

The http://localhost:9200/_plugin/marvel/ concerned the version 1.x of marvel that runs on elasticsearch 1.x


(Prakhar Singh) #5

Thanks @tanguy , the suggestion worked. The issue was arising because of following installation procedure for 1.x
Following the link worked fine.
Thanks,
Prakhar


(Tanguy) #6

Great, thanks


(system) #7