Having trouble with Marvel Installation recommended from the site

monitoring

#1

I've been stuck on this for about a day. I downloaded and installed ElasticSearch 2.3.3 on my redhat vm. I am trying to follow the get started video on the site but not one of the installation commands from the video has worked for me, so I've tried following installation methods from the guide.

I downloaded the rpm and entered the following commands to install:

cd /usr/share/elasticsearch
bin/plugin -DproxyHost=... -DproxyPort=... install license
bin/plugin -DproxyHost=... -DproxyPort=... install marvel-agent

I then started my ElasticSearch node and went to localhost:9200/_plugin/marvel but nothing popped up.

I then thought it might be because I only downloaded the agent and not marvel, so I tried installing marvel from the cmd line, but I constantly getting a FileNotFound exception

bin/plugin -DproxyHost=... -DproxyPort=... install marvel

I then manually downloaded marvel-2.3.3.zip and tried installing it manually

bin/plugin -DproxyHost=... -DproxyPort=... install --verbose file://.../marvel-2.3.3.tar.gz

but I'm told the zip is missing a plugin-descriptor.properties file

Verifying file:/home1/isuser/Downloads/marvel-2.3.3.tar.gz checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: Could not find plugin descriptor 'plugin-descriptor.properties' in plugin zip

I really need some help. This is very frustrating. I still need to install Kibana but if that installation is anything near as infuriating as this one I'm not looking forward to it...


(Chris Earle) #2

As you have downloaded the file locally, what happens if you remove the -Dproxy settings for the last attempt?


(Chris Earle) #3

Ah, nevermind. I think I noticed the issue via the StackOverflow issue:

cd /usr/share/elasticsearch
bin/plugin -DproxyHost=... -DproxyPort=... install license
bin/plugin -DproxyHost=... -DproxyPort=... install marvel-agent

This is all that needs to be installed in Elasticsearch 2.x to make Marvel monitor Elasticsearch. The Marvel Agent monitors the node, with a dependency on the license plugin, then ships the data where ever it's configured to go (to the same node, by default).

The third plugin that you're trying to install is the Marvel UI component. Starting with ES 2.x, the UI component is a part of Kibana and not Elasticsearch.

As such, you should be installing that plugin in Kibana. As you are trying to use Marvel 2.3.3, you should be using Kibana 4.5 (so Kibana 4.5.1 as of now). From Kibana, you can install it there:

bin/kibana plugin --install elasticsearch/marvel/latest

NOTE: The syntax of the plugin commands will change in Elasticsearch 5.x and Kibana 5.x and this will be greatly simplified to literally being the same file for both Elasticsearch and Kibana, but both applications will still be needed for both sides: monitoring and the UI.

bin/elasticsearch-plugin install x-pack
bin/kibana-plugin install x-pack

#4

Thanks for the reply. I tried installing through kibana but I am behind a proxy. do you know the proxy options for the bin/kibana command? I tried -DproxyHost but I got "unknown option -D"


(Chris Earle) #5

-DproxyHost (et al) are Java system properties. Kibana is written using node.js, so it doesn't use them. Kibana's script apparently doesn't expose a mechanism for using a proxy, so you'll have to use the local installation approach:

bin/kibana plugin --install marvel --url file://path/to/file

Note that you must supply the name when using this approach.


(system) #6