Marvel and Sense Plugin Installation does not work


(Abhijit) #1

I have tried the online and offline instructions for installing marvel and sense, but nothing works. I have ES 2.2.1 and Kibana 4.4.2

I tried

plugin install marvel-agent

but i get

Installing marvel-agent...
Trying https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/marvel-agent/2.2.0/marvel-agent-2.2.0.zip ...
ERROR: failed to download out of all possible locations..., use --verbose to get detailed information

same error for

bin/plugin install license

bin/kibana plugin --install elasticsearch/marvel/latest

so then i tried downloading the files and follow instructions on

https://www.elastic.co/guide/en/marvel/current/installing-marvel.html#offline-installation

i tried

plugin install file:///C:/Users/xyz/ElasticSearch/zips/marvel-agent-2.2.0.zip

but i get

-> Installing from file:/C:/Users/xyz/ElasticSearch/zips/marvel-agent-2.2.0.zip...
Trying file:/C:/Users/xyz/ElasticSearch/zips/marvel-agent-2.2.0.zip ...
Downloading ..DONE
Verifying file:/C:/Users/xyz/ElasticSearch/zips/marvel-agent-2.2.0.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)

same for

plugin install file:///C:/Users/xyz/ElasticSearch/zips/license-2.2.0.zip

and finally for

kibana plugin --install marvel --url file:///C:/Users/xyz/ElasticSearch/zips/marvel-2.2.0.tar.gz

i get

Installing marvel
Attempting to transfer from file:///C:/Users/xyz/ElasticSearch/zips/marvel-2.2.0.tar.gz
Error: ENOTFOUND
Plugin installation was unsuccessful due to error "No valid url specified."

Please point out what i am doing wrong.


(system) #2