Upgrade to logstash 1.3.3 and elasticsearch 0.90.9 IBM Java

Hi all,
My project currently uses Logstash 1.1.9, elasticsearch 0.20.4 and Kibana.
Now, we are upgrading logstash to 1.3.3 and elasticsearch to 0.90.9.

java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pxa6470sr7fp1-20140708_01(SR7 FP1))
IBM J9 VM (build 2.6, JRE 1.7.0 Linux amd64-64 Compressed References
20140627_204598 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR7_20140627_0924_B204598
JIT - r11.b06_20140409_61252.04
GC - R26_Java726_SR7_20140627_0924_B204598_CMPRSS
J9CL - 20140627_204598)
JCL - 20140707_01 based on Oracle 7u65-b16

SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2

In the process, I am facing the following issues

  1. Logstash, during startup displays this warning.

The signal INT is in use by the JVM and will not work correctly on this

platform
Using milestone 2 input plugin 'file'. This plugin should be stable, but
if you see strange behavior, please let us know! For more information on
plugin milestones, see http://logstash.net/docs/1.3.3/plugin-milestones
{:level=>:warn}

You are using a deprecated config setting "type" set in multiline.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. You can achieve this same behavior with the
new conditionals, like: if [type] == "sometype" { multiline { ... } }. If
you have any questions about this, please visit the #logstash channel on
freenode irc. {:name=>"type", :plugin=><LogStash::Filters::Multiline --->,
:level=>:warn}

You are using a deprecated config setting "pattern" set in grok.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. You should use this instead: match => {
"message" => "your pattern here" } If you have any questions about this,
please visit the #logstash channel on freenode irc. {:name=>"pattern",
:plugin=><LogStash::Filters::Grok --->, :level=>:warn}

You are using a deprecated config setting "singles" set in grok.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. This behavior is the default now, you don't
need to set it. If you have any questions about this, please visit the
#logstash channel on freenode irc. {:name=>"singles",
:plugin=><LogStash::Filters::Grok --->, :level=>:warn}

You are using a deprecated config setting "remove" set in mutate.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. If you have any questions about this, please
visit the #logstash channel on freenode irc. {:name=>"remove",
:plugin=><LogStash::Filters::Mutate --->, :level=>:warn}

  1. Elasticsearch logs have this message

log4j, [2014-10-13T10:33:56.528] INFO: org.elasticsearch.discovery.zen:

[Grey-Summers, Jean] failed to send join request to master
[[Bombshell][ftMvM0VZRNe-VD6atUwvbg][inet[/127.0.0.1:9100]]], reason
[org.elasticsearch.transport.RemoteTransportException:
[Bombshell][inet[/127.0.0.1:9100]][discovery/zen/join];
org.elasticsearch.transport.RemoteTransportException: [Grey-Summers,
Jean][inet[/10.10.150.185:9300]][discovery/zen/join/validate];
java.io.IOException: Expected handle header, got [22]]
log4j, [2014-10-13T10:33:59.534] WARN: org.elasticsearch.transport.netty:
[Grey-Summers, Jean] Message not fully read (request) for [32] and action
[discovery/zen/join/validate], resetting

Though the index folders are generated, kibana doesn't display anything.
"No events matched.Sorry, I couldn't find anything for that query. Double
check your spelling and syntax."

My questions:

  1. Is IBM Java compatible with the above mentioned versions of logstash and
    elasticsearch?
  2. How to proceed with the upgrade? From this page, I understand that
    logstash 1.3.3 is compatible with elasticsearch 0.90.9

Any help will be highly appreciated.

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/66bb84b6-bc21-41d3-ad03-7bbb9dc2a245%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

//How to proceed with the upgrade? From this page, I understand that
logstash 1.3.3 is compatible with elasticsearch 0.90.9
Missed the link -- http://logstash.net/docs/1.3.3/outputs/elasticsearch

On Monday, October 13, 2014 5:32:39 PM UTC+5:30, karthick r wrote:

Hi all,
My project currently uses Logstash 1.1.9, elasticsearch 0.20.4 and Kibana.
Now, we are upgrading logstash to 1.3.3 and elasticsearch to 0.90.9.

java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pxa6470sr7fp1-20140708_01(SR7 FP1))
IBM J9 VM (build 2.6, JRE 1.7.0 Linux amd64-64 Compressed References
20140627_204598 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR7_20140627_0924_B204598
JIT - r11.b06_20140409_61252.04
GC - R26_Java726_SR7_20140627_0924_B204598_CMPRSS
J9CL - 20140627_204598)
JCL - 20140707_01 based on Oracle 7u65-b16

SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2

In the process, I am facing the following issues

  1. Logstash, during startup displays this warning.

The signal INT is in use by the JVM and will not work correctly on this

platform
Using milestone 2 input plugin 'file'. This plugin should be stable, but
if you see strange behavior, please let us know! For more information on
plugin milestones, see http://logstash.net/docs/1.3.3/plugin-milestones
{:level=>:warn}

You are using a deprecated config setting "type" set in multiline.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. You can achieve this same behavior with the
new conditionals, like: if [type] == "sometype" { multiline { ... } }. If
you have any questions about this, please visit the #logstash channel on
freenode irc. {:name=>"type", :plugin=><LogStash::Filters::Multiline --->,
:level=>:warn}

You are using a deprecated config setting "pattern" set in grok.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. You should use this instead: match => {
"message" => "your pattern here" } If you have any questions about this,
please visit the #logstash channel on freenode irc. {:name=>"pattern",
:plugin=><LogStash::Filters::Grok --->, :level=>:warn}

You are using a deprecated config setting "singles" set in grok.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. This behavior is the default now, you don't
need to set it. If you have any questions about this, please visit the
#logstash channel on freenode irc. {:name=>"singles",
:plugin=><LogStash::Filters::Grok --->, :level=>:warn}

You are using a deprecated config setting "remove" set in mutate.
Deprecated settings will continue to work, but are scheduled for removal
from logstash in the future. If you have any questions about this, please
visit the #logstash channel on freenode irc. {:name=>"remove",
:plugin=><LogStash::Filters::Mutate --->, :level=>:warn}

  1. Elasticsearch logs have this message

log4j, [2014-10-13T10:33:56.528] INFO: org.elasticsearch.discovery.zen:

[Grey-Summers, Jean] failed to send join request to master
[[Bombshell][ftMvM0VZRNe-VD6atUwvbg][inet[/127.0.0.1:9100]]], reason
[org.elasticsearch.transport.RemoteTransportException:
[Bombshell][inet[/127.0.0.1:9100]][discovery/zen/join];
org.elasticsearch.transport.RemoteTransportException: [Grey-Summers,
Jean][inet[/10.10.150.185:9300]][discovery/zen/join/validate];
java.io.IOException: Expected handle header, got [22]]
log4j, [2014-10-13T10:33:59.534] WARN:
org.elasticsearch.transport.netty: [Grey-Summers, Jean] Message not fully
read (request) for [32] and action [discovery/zen/join/validate], resetting

Though the index folders are generated, kibana doesn't display anything.
"No events matched.Sorry, I couldn't find anything for that query. Double
check your spelling and syntax."

My questions:

  1. Is IBM Java compatible with the above mentioned versions of logstash
    and elasticsearch?
  2. How to proceed with the upgrade? From this page, I understand that
    logstash 1.3.3 is compatible with elasticsearch 0.90.9

Any help will be highly appreciated.

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0ec6ea1d-1725-452d-89f9-94abe9266963%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.